Flush and therefore Assert are not implemented on RDFDataSources that come from http URLs

RESOLVED DUPLICATE of bug 55699

Status

()

Core
RDF
--
enhancement
RESOLVED DUPLICATE of bug 55699
17 years ago
14 years ago

People

(Reporter: Stephen Harris, Assigned: Chris Waterson)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
In rdf/base/src/nsRDFXMLDataSource.cpp:753

// We don't accept assertions unless we're writable (except in the
// case that we're actually _reading_ the datasource in).

This is inconvenient, and I would really like to be able to Flush() RDF data
sources back to http URLs as I can already for file URLs. The TODO list for that
file says:

"Eventually, it'd be great if we could open an arbitrary nsIOutputStream on
*any* URL, and Netlib could just do the magic."

I don't know how realistic that is, but there doesn't seem to be an RFE for it
in Bugzilla, so this is that RFE. In particular it would be nice if Flush() on
an RDF source wrote the (edited) contents back via HTTP-POST or something.

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 55699 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

14 years ago
tever is not RDF QA anymore
QA Contact: tever → nobody
You need to log in before you can comment on or make changes to this bug.