Multiple listings of the same IMAP account (intermittent problem)

RESOLVED INCOMPLETE

Status

Thunderbird
Folder and Message Lists
RESOLVED INCOMPLETE
6 years ago
4 years ago

People

(Reporter: WBT, Unassigned)

Tracking

Trunk
x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
I have a few accounts, mostly IMAP, and two in particular have fairly large and complex folder structures, which effectively occupy the entire left panel, requiring scrolling the folder list to view a different account.
Occasionally, especially after Thunderbird has been open for a while, I notice that one of the accounts is in the list multiple times, e. g. at the top and also at the bottom.  Today, I noticed an account that was there in triplicate. 
The account is also repeated in the Account Manager.  It looks exactly like somebody added another account with the same name and settings (as far as I can tell). 
Historically, I've tried to address this by deleting (removing) the second account instance from the Account Manager.  However, this has had the effect of also deleting the original account instance, and I have to go through the process of re-establishing that setup.  I figured this was because the new instances had the same name as the original.  Today when I notices an account in triplicate, I went to rename the second, and observed that it renamed all three.  I did not delete any of the three accounts.  After a reboot, only the original copies of the accounts remained; it had self-corrected to the desired behavior.

I'm sorry I haven't yet isolated the particular conditions that trigger this, but is anybody aware of an existing bug on this issue?  None of the queries I tried turned up any.  Alternatively, does anybody else have a better fix on what makes this happen?

Comment 1

6 years ago
What is your TB version? Can you make a screenshot of this? When it happens, can you look in prefs.js file if the account prefs (mail.server.server*) are duplicated there too?
Version: unspecified → Trunk

Comment 2

6 years ago
WBT ??

(In reply to :aceman from comment #1)
> What is your TB version? Can you make a screenshot of this? When it happens,
> can you look in prefs.js file if the account prefs (mail.server.server*) are
> duplicated there too?
(Reporter)

Comment 3

6 years ago
I've been waiting to see it duplicated in Safe Mode, per usual request.  This takes a while because I don't often run in Safe Mode.

Comment 4

5 years ago
I don't think we have other resorts of this.
and there isn't enough information here to pursue a solution or reproduce.
please check error console also next time you see it.
prefs.js to a developer might allso be helpful
thanks
Status: NEW → UNCONFIRMED
Ever confirmed: false
Whiteboard: [closeme 2012-10-01]

Comment 5

5 years ago
Resolved per whiteboard.
Whiteboard: [closeme 2012-10-01]
(In reply to WBT from comment #0)
> The account is also repeated in the Account Manager.  It looks exactly like
> somebody added another account with the same name and settings (as far as I
> can tell).

Phenomenon of bug 303542?

How did you create accounts in Tb?
Did you change Server name/User name after account creation via Account Wizard?
Have you ckecked account definitions in prefs.js  before you tried to delete dup'ed account when you saw your problem?
(Reporter)

Comment 7

5 years ago
(In reply to WADA from comment #6)

> Phenomenon of bug 303542?
I don't think so; that one says "problem appeared after adding another account with the same email address" and this occurs when no e-mail address has been recently hadded. 


> How did you create accounts in Tb?
With Add Account in Account Manager, I believe, or the firstrun wizard...that process has changed a lot in recent years.

> Did you change Server name/User name after account creation via Account
> Wizard?
I don't believe so, except maybe initially changing it from the defaults that the wizard assumed, to get the mail account working right. 

> Have you ckecked account definitions in prefs.js  before you tried to delete
> dup'ed account when you saw your problem?

Not that I can recall.  Next time I see this, I'll try to remember to find a prefs.js file and see what I see there.

Comment 8

4 years ago
(In reply to WBT from comment #7)
> (In reply to WADA from comment #6)
> 
> > Phenomenon of bug 303542?
> I don't think so; that one says "problem appeared after adding another
> account with the same email address" and this occurs when no e-mail address
> has been recently hadded. 
> 
> 
> > How did you create accounts in Tb?
> With Add Account in Account Manager, I believe, or the firstrun
> wizard...that process has changed a lot in recent years.
> 
> > Did you change Server name/User name after account creation via Account
> > Wizard?
> I don't believe so, except maybe initially changing it from the defaults
> that the wizard assumed, to get the mail account working right. 
> 
> > Have you ckecked account definitions in prefs.js  before you tried to delete
> > dup'ed account when you saw your problem?
> 
> Not that I can recall.  Next time I see this, I'll try to remember to find a
> prefs.js file and see what I see there.

what did you find?

Do you still see this when using version 24?
Flags: needinfo?(firstpeterfourten)
Whiteboard: [closeme 2014-03-01]
(Reporter)

Comment 9

4 years ago
I'm not on the latest version; upgrades seem to break some add-ons that I regard as core functionality for my use case.  Therefore, I can't accurately report on whether it's been fixed or not.
Flags: needinfo?(firstpeterfourten)

Comment 10

4 years ago
Resolved per whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2014-03-01]
You need to log in before you can comment on or make changes to this bug.