[Mac] Links inside headings are prepresented by an "object replacement character", their text should be expanded.

VERIFIED DUPLICATE of bug 712923

Status

()

Core
Disability Access APIs
P1
normal
VERIFIED DUPLICATE of bug 712923
6 years ago
6 years ago

People

(Reporter: MarcoZ, Assigned: hub)

Tracking

(Blocks: 1 bug)

Trunk
x86_64
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
Spin off from bug 712923 comment #16.

STR:
1. Open http://www.marcozehe.de in a build that contains the fix for bug 712923.
2. Start navigating right by Ctrl+Option+RightArrow, until you encounter the first level 2 heading.

Result: VoiceOver says "Heading level 2, object replacement character".
Expected: VoiceOver should say "Heading level 2 " plus the title of the blog item that is being linked to.

The reason is that, in the Windows equivalent called IAccessibleText, links are represented by a simgle character, and an actual accessible child. We should expand that so the link is properly rendered on mac.
(Reporter)

Comment 1

6 years ago
This is actually missing out on text content, and has no workaround, so it needs to be fixed one way or another quite soon.
Priority: -- → P1
(Assignee)

Comment 2

6 years ago
Voice Over Expect that the AXHeading have an AXLink and then an AXStaticText
Currently we skip the AXLink. Will fix.
(Assignee)

Comment 3

6 years ago
This happen because the heading is a link.
(Assignee)

Updated

6 years ago
Assignee: nobody → hub
(Assignee)

Comment 4

6 years ago
This actually fixed by the last rework of bug 712923, and will be actually fixed when the patch lands.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 712923
(Reporter)

Comment 5

6 years ago
Verified in a local build that contains the now landed bug 712923 and also bug 712927. Links are being recognized with their full text inside headings now and no longer by an embedded char.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.