Right Clicking on links brings up password dialog box

VERIFIED WORKSFORME

Status

Core Graveyard
Security: UI
P3
normal
VERIFIED WORKSFORME
17 years ago
a year ago

People

(Reporter: varada, Assigned: David P. Drinan)

Tracking

1.0 Branch
psm2.1
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Right clicking on any of the story links in this page brings up the Password
Dialog box :"Please enter the personal security password ..". Clicking cancel
makes it go away and the context menu appears.
(Reporter)

Comment 1

17 years ago
forgot to add the necc build info
WinNT 2001030804

Comment 3

17 years ago
*** Bug 71942 has been marked as a duplicate of this bug. ***
blake, this does kinda sound like bug 71705. what d'you think?

Comment 5

17 years ago
It does, but I only see one onclick handler in the page (and it's not on any of 
the story links), plus that password dialog sounds like it belongs to the 
crypto team, not the page (but I can't reproduce this, so I can't tell....)
hrm, i cannot get the password dialog to appear either on this page.

varada, is this still a problem for you?

gonna pass this to the crypto --junruh, pls do punt back if that's not the right
place.
Assignee: ben → ddrinan
Component: XP Apps: GUI Features → Security: Crypto
QA Contact: sairuh → junruh

Comment 7

17 years ago
*** Bug 73227 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

17 years ago
Component: Security: Crypto → Client Library
Product: Browser → PSM
Version: other → 2.0

Comment 8

17 years ago
The test site leads to a "Not found" page.  I can't get the password dialog box 
to appear.

Comment 9

17 years ago
Still present with build 2001042704 on win98SE.
When I get into it, I have to cancel the dialog box 18 times before it is gone
for good.
It does occur on this Bugzilla page.

Comment 10

17 years ago
I can't reproduce this either.  Can you supply another URL?
Target Milestone: --- → 2.0

Comment 11

17 years ago
Well, this page (or any bugzilla page) is the best example I can think of. It
nearly occurs each time I try.

BTW, it has been present for a long time for me but it was such a big bug (very
annoying) that I thought everybody would report it. Now, it seems to be quite
scarce. That leads me to think that it can be installation and / or environment
related. I mean that the way I installed Mozilla different times on my computer
might differ from others.

Do you have any suggestion to track the problem down?

Comment 12

17 years ago
Does this bug go away when you login to PSM?

Comment 13

17 years ago
Even if I have no reason to login to PSM, the password dialog box doesn't come
up anymore (at least for a while) after I have typed my password.

Comment 14

17 years ago
i was a reporter of the bug (well, a duplicate), and im happy to report that
it's fixed in 0.9.
cheers
and thanks to all.

Comment 15

17 years ago
Marking fixed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 16

17 years ago
Please REOPEN!
I just tried it on 2001050904 and it DOESNTWORKFORME!
It might be fixed on 0.9 but it's not in the trunk!
reopening based on Patrick's comments...

Patrick, have you tried a clean install?  Delete previous version and install?

Also, does this occur with all profiles?  Does creating a new profile help?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 18

17 years ago
> Patrick, have you tried a clean install?  Delete previous version and install?

I usually download the talkback versions. It is then a zip file: I delete the
contents of Mozilla's directory and then put the contents of the zip file. It is
no real install.

> Also, does this occur with all profiles?  Does creating a new profile help?

Good point, the problem doesn't occur with a new profile. The origin of the
problem (corruption?) remains to be found. Any other question to find out?

(Assignee)

Comment 19

17 years ago
-> p3
Priority: -- → P3
(Assignee)

Comment 20

17 years ago
*** Bug 79734 has been marked as a duplicate of this bug. ***

Comment 21

17 years ago
Mass reassigning target to 2.1
Target Milestone: 2.0 → 2.1

Updated

17 years ago
Keywords: nsenterprise

Comment 22

17 years ago
remove nsenterprise
Keywords: nsenterprise

Comment 23

17 years ago
Is this still a problem in the latest builds?

Comment 24

17 years ago
I think I haven't seen it recently. I will confirm in a few days.

Comment 25

17 years ago
Marking worksforme. Reopen if you see this again.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 26

17 years ago
Worksforme too! Sorry I had forgotten to confirm. I haven't seen it a long while.

Comment 27

17 years ago
verified.
Status: RESOLVED → VERIFIED

Updated

13 years ago
Component: Security: UI → Security: UI
Product: PSM → Core

Updated

10 years ago
Version: psm2.0 → 1.0 Branch
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.