Last Comment Bug 718640 - Account Provisioner link to view providers in other languages is always displayed
: Account Provisioner link to view providers in other languages is always displ...
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Mail Window Front End (show other bugs)
: 10 Branch
: x86 All
: -- normal (vote)
: Thunderbird 12.0
Assigned To: Mike Conley (:mconley)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-17 06:51 PST by Mike Conley (:mconley)
Modified: 2012-01-25 08:49 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed


Attachments
Patch v1 (5.79 KB, patch)
2012-01-17 07:08 PST, Mike Conley (:mconley)
bwinton: review+
standard8: approval‑comm‑aurora+
Details | Diff | Splinter Review

Description Mike Conley (:mconley) 2012-01-17 06:51:12 PST
We display the link that allows users to choose providers in languages other than their own, even when no providers exist.

I noticed this after Sancus removed the fake Yandex entry from the provider list.
Comment 1 Mike Conley (:mconley) 2012-01-17 07:08:22 PST
Created attachment 589185 [details] [diff] [review]
Patch v1

It looks like at some point we switched the div from being named "otherLanguages" to "otherLangDesc", and so the display:none; CSS property was never applied.

I've also added a regression test.
Comment 2 Blake Winton (:bwinton) (:☕️) 2012-01-17 07:11:09 PST
Comment on attachment 589185 [details] [diff] [review]
Patch v1

Review of attachment 589185 [details] [diff] [review]:
-----------------------------------------------------------------

Seems good and nice catch!

r=me.
Comment 3 Mike Conley (:mconley) 2012-01-25 08:49:23 PST
Committed to comm-central as http://hg.mozilla.org/comm-central/rev/221b010fd6a1

Committed to comm-aurora as http://hg.mozilla.org/releases/comm-aurora/rev/de5589a5f7fb

Note You need to log in before you can comment on or make changes to this bug.