Last Comment Bug 718733 - Allow JSAPI tests with principals
: Allow JSAPI tests with principals
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla12
Assigned To: Blake Kaplan (:mrbkap) (please use needinfo!)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-17 10:38 PST by Blake Kaplan (:mrbkap) (please use needinfo!)
Modified: 2012-01-26 16:01 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Proposed fix (1.05 KB, patch)
2012-01-17 10:40 PST, Blake Kaplan (:mrbkap) (please use needinfo!)
jorendorff: review+
mrbkap: checkin+
Details | Diff | Review

Description Blake Kaplan (:mrbkap) (please use needinfo!) 2012-01-17 10:38:46 PST
Currently, the compartments and global objects that jsapi-test creates have a null principal. For some tests, it is useful to be able to have principals. I could override createGlobal, but it turns out that it's pretty easy to add this directly to tests.h.
Comment 1 Blake Kaplan (:mrbkap) (please use needinfo!) 2012-01-17 10:40:50 PST
Created attachment 589235 [details] [diff] [review]
Proposed fix
Comment 2 Blake Kaplan (:mrbkap) (please use needinfo!) 2012-01-26 03:57:06 PST
Comment on attachment 589235 [details] [diff] [review]
Proposed fix

https://hg.mozilla.org/integration/mozilla-inbound/rev/04af5f29e0bf
Comment 3 Marco Bonardo [::mak] 2012-01-26 16:01:07 PST
https://hg.mozilla.org/mozilla-central/rev/04af5f29e0bf

Note You need to log in before you can comment on or make changes to this bug.