TEST-UNEXPECTED-FAIL | test-install-xpi.js | timed out waiting for modal dialog

RESOLVED FIXED in Thunderbird 12.0

Status

Thunderbird
Testing Infrastructure
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: standard8, Assigned: standard8)

Tracking

({intermittent-failure})

Trunk
Thunderbird 12.0
x86
Mac OS X
intermittent-failure
Bug Flags:
in-testsuite +

Thunderbird Tracking Flags

(thunderbird10 fixed, thunderbird11 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
EXCEPTION: Timeout waiting for modal dialog to open.
    at: utils.js line 429
       TimeoutError("Timeout waiting for modal dialog to open.") utils.js 429
       waitFor((function () this.waitingForOpen == null && this.monitorizeClose()),"Timeout waiting for modal dialog to open.",10000,100,[object Object]) utils.js 467
       WindowWatcher_waitForModalDialog("Addons:Install",(void 0)) test-window-helpers.js 398
       wait_for_modal_dialog("Addons:Install") test-window-helpers.js 631
       test_install_xpi_offer() test-install-xpi.js 158
            frame.js 557
            frame.js 626
            frame.js 669
            frame.js 497
            frame.js 675
            server.js 179
            server.js 183
(Assignee)

Comment 1

6 years ago
Created attachment 589284 [details] [diff] [review]
The fix

This has been happening randomly for a while but has just got a lot worse, I thought there was a bug filed but apparently not.

As it happens, the cause is AMO having a few issues (according to the status page), which is the perfect opportunity to debug. It appears that when we install an add-on there's a ping in to the cache to check for compatibility updates.

There's a pref that we can use to turn this off - extensions.getAddons.cache.enabled.

Doing an export NSPR_LOG_MODULES=nsHttp:5 and grepping the log, with the pref as its default, I was seeing "Host: services.addons.mozilla.org", but with the pref turned off, there's no such line.

This should prevent our tests failing when there's no amo.
Attachment #589284 - Flags: review?(mconley)
Comment on attachment 589284 [details] [diff] [review]
The fix

Solid patch - looks good to me.  All content-tabs tests are passing locally.

I don't think we test add-ons elsewhere, so I assume the rest of the tests are fine.  r=me.
Attachment #589284 - Flags: review?(mconley) → review+
(Assignee)

Comment 3

6 years ago
Checked in: http://hg.mozilla.org/comm-central/rev/72e27df65c84
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 12.0
(Assignee)

Updated

6 years ago
Attachment #589284 - Flags: approval-comm-beta+
Attachment #589284 - Flags: approval-comm-aurora+
(Assignee)

Comment 4

6 years ago
Checked into branches:

http://hg.mozilla.org/releases/comm-aurora/rev/9f72fdf1b860
http://hg.mozilla.org/releases/comm-beta/rev/df9f1a44e2e5
status-thunderbird11: --- → fixed
status-thunderbird12: --- → fixed
(Assignee)

Updated

6 years ago
status-thunderbird10: --- → fixed
status-thunderbird12: fixed → ---
(Assignee)

Updated

6 years ago
Attachment #589284 - Flags: approval-comm-beta+
Keywords: intermittent-failure
Whiteboard: [tb-orange]
You need to log in before you can comment on or make changes to this bug.