need to run `cfx xpi` twice for a freshly generated addon

RESOLVED DUPLICATE of bug 613587

Status

RESOLVED DUPLICATE of bug 613587
7 years ago
7 years ago

People

(Reporter: k0scist, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [jetpack+talos])

(Reporter)

Description

7 years ago
for `cfx xpi` (and `cfx run`, etc), you have to run them twice to do what you actually want to do.  Ideally, it would be done with one pass.

Repro steps:

│hg clone http://hg.mozilla.org/projects/addon-sdk
destination directory: addon-sdk
requesting all changes
adding changesets
adding manifests
adding file changes
added 2799 changesets with 6762 changes to 1493 files
updating to branch default
653 files updated, 0 files merged, 0 files removed, 0 files unresolved
│cd addon-sdk/
Welcome to the Add-on SDK. Run 'cfx docs' for assistance.
(addon-sdk)│mkdir helloworld
(addon-sdk)│cd helloworld/
(addon-sdk)│../bin/cfx init
fatal: Not a git repository (or any of the parent directories): .git
* lib directory created
* data directory created
* test directory created
* doc directory created
* README.md written
* package.json written
* test/test-main.js written
* lib/main.js written
* doc/main.md written

Your sample add-on is now ready.
Do "cfx test" to test it and "cfx run" to try it.  Have fun!
(addon-sdk)│../bin/cfx xpi
fatal: Not a git repository (or any of the parent directories): .git
No 'id' in package.json: creating a new ID for you.
package.json modified: please re-run 'cfx xpi'
(addon-sdk)│../bin/cfx xpi
fatal: Not a git repository (or any of the parent directories): .git
Exporting extension to helloworld.xpi.
I think this would be covered by bug 613587.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 613587
You need to log in before you can comment on or make changes to this bug.