If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Hardware acceleration is disabled on Intel HD graphics

RESOLVED DUPLICATE of bug 628129

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 628129
6 years ago
6 years ago

People

(Reporter: Theodore, Unassigned)

Tracking

12 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20120117 Firefox/12.0a1
Build ID: 20120117073409

Steps to reproduce:

I bought a new HP dv7t-6b00 Quad Edition notebook with switchable Intel/AMD graphics.  Hardware acceleration works perfectly in IE 9 and Chrome, but not in Firefox.  The problem occurs with the most recent nightly builds, as well as the current stable version of Firefox.  I'm running the latest graphics driver available from HP.


Actual results:

The Troubleshooting Information page displays the following:

Graphics:

Adapter Description:  Intel(R) HD Graphics Family
Vendor ID:  0x8086
Device ID:  0x0116
Adapter RAM:  Unknown
Adapter Drivers:  igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
Driver Version:  8.830.6.3000
Driver Date:  5-7-2011
Direct2D Enabled:  Blocked for your graphics driver version.
DirectWrite Enabled:  false (6.1.7601.17563)
ClearType Parameters:  ClearType parameters not found
WebGL Renderer:  Google Inc. -- ANGLE (Intel(R) HD Graphics Family) -- OpenGL ES 2.0 (ANGLE 1.0.0.930)
GPU Accelerated Windows:  0


Expected results:

Since hardware acceleration works fine in other browsers, it should also work in Firefox.

Comment 1

6 years ago
What Intel HD GPU model is that?

Also see https://wiki.mozilla.org/Blocklisting/Blocked_Graphics_Drivers for various reasons the driver could be blocked.

You can also go to about:config and find gfx.direct2d.force-enabled, toggle it to true and see if it really works. Maybe Firefox has real reasons to block it.
(Reporter)

Comment 2

6 years ago
GPU-Z says my GPU is a "GT2", which according to AnandTech is a standard Sandy Bridge integrated chip.  The hardware acceleration seems to work perfectly when I force-enable it in about:config (I got a score of 7 seconds in Microsoft's Speed Reading test), so I don't think Firefox has any reason to block it.

http://ie.microsoft.com/testdrive/Performance/SpeedReading/default.html
http://www.anandtech.com/show/3885/sandy-bridge-graphics-update

Comment 3

6 years ago
I am using HD 2000 in a Sandy Bridge Pentium G620 and FF enables Direct2D on it fine.

How many FPS do you get here: http://hacks.mozilla.org/2010/09/hardware-acceleration/ ?

Maybe you are hitting this problem:
Our current blacklisting implementation does not properly support dual-GPU systems (bug 628129). Can you disable any of the cards? Or make the AMD card primary/used?
(Reporter)

Comment 4

6 years ago
I get 60+ FPS in that test (with HW acceleration force-enabled).  The dual-GPU bug must be the problem.  Hopefully it will be fixed ASAP.
(Reporter)

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 628129
You need to log in before you can comment on or make changes to this bug.