Google Charts Wizards uses excessive memory

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: Frank Nestel, Unassigned)

Tracking

10 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:10.0) Gecko/20100101 Firefox/10.0
Build ID: 20120111092507

Steps to reproduce:

I had a completely well running Firefox 10 beta (plenty of tabs, plenty of add ons, but all fine), then opened 
http://code.google.com/intl/de-DE/apis/chart/image/docs/chart_wizard.html.



Actual results:

The Wizard stayed in the state "Loading..." forever, Firefox became frozen within a minute or so. On closer (repeated) inspection the memory usage of the Firefox process jumps from 450 MB to 1900 MB. Since this is a ancient 2 GB machine this rendered Firefox completely inresponsive, only swapping forever.


Expected results:

I would have liked to see the Google Chart Wizard and I would have liked to continue working with the current Firefox instance. Instead I had to shut it down, and disable the tab which contained Google Charts Wizard on restart, since otherwise the restart got hung again ASAP.
(Reporter)

Comment 1

7 years ago
This behaviour is completely reproducable on my Firefox instance, I can do it over and over.

Comment 2

7 years ago
WFM on Mozilla/5.0 (Windows NT 5.1; rv:12.0a1) Gecko/20120118 Firefox/12.0a1 ID:20120118031059

Does the issue still occur if you start Firefox in Safe Mode? http://support.mozilla.com/en-US/kb/Safe+Mode

How about with a new, empty profile? http://support.mozilla.com/en-US/kb/Basic%20Troubleshooting#w_8-make-a-new-profile
(Reporter)

Comment 3

7 years ago
An empty profile fixes the problem.

And now? Is there a way to copy add ons from one profile to the other. Even if it is, the testing of all possible pair interactions of add ons would last for way too long. I'd go for bugzilla as a suspect first.

Comment 4

7 years ago
Really to track it down, you would need to follow http://support.mozilla.com/en-US/kb/Troubleshooting+extensions+and+themes

If you just move back all the extensions chances are it will just happen again. You can try attaching (as a text attachment) the contents of about:support from the "bad" profile and we can see if anything jumps out...but 99% it is going to be an extension
(Reporter)

Comment 5

7 years ago
I did not want to reinstall all extensions. What I'd dream of, would be a convenient tool to copy/merge add ons between two profiles, i.e. show a list of add ons in either profile and then move/copy add ons back and forth between those two by simple mouse clicks. Never mind.

Do you have access to mozilla crash reports? I once more retried this bug, and tried to do an about:memory during the crash (it takes a few seconds until the process crashes on 2 GB memory). I could switch from the Google Charts tab back to the about:memory tab, could even click "refresh", but then ended up with a sandclock until Mozilla crashed. 

I copied the following string in the textual description of the crash, in case you can do full text search: ID967846742364230878

Comment 6

7 years ago
Please provide a crash id from about:crashes -> https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report
(Reporter)

Comment 7

7 years ago
Sorry, I had a few days of that particular computer with that particular crash.

Here we are, the id is bp-e37368e2-6755-4d6b-aadf-dcf822120120
i.e. I get a link there: https://crash-stats.mozilla.com/report/index/bp-e37368e2-6755-4d6b-aadf-dcf822120120

Comment 8

7 years ago
Any other crash IDs? That one has a corrupt stack...
(Reporter)

Comment 9

7 years ago
Corrupt stack seems to be "part of it", I tried the above maneuvre once more and again Firefox crashed, sending bp-6bf94bad-507b-440e-b503-d22852120125

But there is a difference. This time AFTER RESTART, the chart tab stayed open (last time the reopen skipped that tab) and I can use the google wizard and the firefox process has "only" moderate size (486 MB virtual, 281 MB working set). I am going to close the "Chat Wizard" tab now and reopen it from url. But I am closing this comment first!
(Reporter)

Comment 10

7 years ago
Hmm, I can now close the tab with "Chart Wizard", I can even close the wizards tab, close Firefox and then restart, it does not crash again since that particular restart?! Is this considered a fix, or can there be any caching involved, rendering the problem irreproducible?

Comment 11

7 years ago
Frank -> Let's close the report for now and if you can reproduce again post back with the latest crash id.

Sometimes the corrupt stacks are caused by out of memory conditions...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.