Last Comment Bug 718961 - History-visited link color
: History-visited link color
Status: VERIFIED FIXED
: regression
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: Trunk
: ARM Android
: P1 normal (vote)
: Firefox 12
Assigned To: (Back on May31) Kartikaya Gupta (email:kats@mozilla.com)
:
Mentors:
Depends on:
Blocks: 715507
  Show dependency treegraph
 
Reported: 2012-01-18 02:02 PST by Carla Nadastean
Modified: 2013-12-10 10:00 PST (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed
verified


Attachments
(1/2) Copy URI into native object wrapper (921 bytes, patch)
2012-01-23 15:40 PST, (Back on May31) Kartikaya Gupta (email:kats@mozilla.com)
blassey.bugs: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Review
(2/2) Fix typo (2.45 KB, patch)
2012-01-23 15:41 PST, (Back on May31) Kartikaya Gupta (email:kats@mozilla.com)
blassey.bugs: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Review

Description Carla Nadastean 2012-01-18 02:02:00 PST
Nightly: Fennec/12.0a1(2012-01-17)
HTC Desire Z (Android 2.3)

Steps to reproduce:
   1. Go to news.google.com or any other page with links
   2. Chose a link that was not visited before
   3. Open it in new tab or tap on it and then go back to the initial page

Expected Result:
The link color is blue and after the visit it changes into purple.

Actual Result:
The visited link color doesn't change after the link was visited.

NOTE:This could be regression from bug 695170.
Comment 1 Brad Lassey [:blassey] (use needinfo?) 2012-01-23 14:24:53 PST
Kats, sounds like we regressed
Comment 2 (Back on May31) Kartikaya Gupta (email:kats@mozilla.com) 2012-01-23 15:40:32 PST
Created attachment 590904 [details] [diff] [review]
(1/2) Copy URI into native object wrapper
Comment 3 (Back on May31) Kartikaya Gupta (email:kats@mozilla.com) 2012-01-23 15:41:08 PST
Created attachment 590905 [details] [diff] [review]
(2/2) Fix typo
Comment 4 (Back on May31) Kartikaya Gupta (email:kats@mozilla.com) 2012-01-23 15:47:49 PST
Regression was introduced in bdabac538e90, which was landed in aurora as bd6bcca22234. So this probably affects aurora as well.
Comment 5 Matt Brubeck (:mbrubeck) 2012-01-23 17:24:32 PST
Yes, Aurora has regressed too.
Comment 8 (Back on May31) Kartikaya Gupta (email:kats@mozilla.com) 2012-01-25 13:33:22 PST
Comment on attachment 590904 [details] [diff] [review]
(1/2) Copy URI into native object wrapper

[Approval Request Comment]
Regression caused by (bug #): 715507
User impact if declined: visited links don't get coloured
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): mobile-only, low-risk
Comment 9 Alex Keybl [:akeybl] 2012-01-25 17:05:43 PST
Comment on attachment 590904 [details] [diff] [review]
(1/2) Copy URI into native object wrapper

[Triage Comment]
Mobile only - approved for Aurora.
Comment 10 Matt Brubeck (:mbrubeck) 2012-01-26 17:40:04 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/651c8c5b6cd3
Comment 11 Matt Brubeck (:mbrubeck) 2012-01-26 17:40:16 PST
and https://hg.mozilla.org/releases/mozilla-aurora/rev/de7cd69f8199
Comment 12 Cristian Nicolae (:xti) 2012-03-02 08:31:57 PST
Verified fixed on:

Firefox 13.0a1 (2012-03-02)
20120302031112
http://hg.mozilla.org/mozilla-central/rev/3a7b9e61c263

--
Device: Samsung Galaxy S2
OS: Android 2.3.4

Note You need to log in before you can comment on or make changes to this bug.