Closed Bug 718964 Opened 10 years ago Closed 10 years ago

TestRun API shouldn't call sys.exit() but throw a test failed specific exception

Categories

(Mozilla QA Graveyard :: Mozmill Automation, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: whimboo, Assigned: whimboo)

References

Details

(Keywords: regression)

Attachments

(1 file)

We should never call sys.exit() in an API. This will blow up any consumer who wants to override some of the class features or use the class differently.

Exactly because of this change in bug 626712, our daily testrun now does not execute the following test-runs if the current one contains at least one test failure.

The upcoming patch will solve this problem by introducing a new exception class, which can be handled by consumers.
Attached patch Patch v1Splinter Review
Attachment #589449 - Flags: review?(dave.hunt)
Attachment #589449 - Flags: review?(dave.hunt) → review+
Landed as:
http://hg.mozilla.org/qa/mozmill-automation/rev/a0c9e113cab7
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Product: Mozilla QA → Mozilla QA Graveyard
You need to log in before you can comment on or make changes to this bug.