[bugsy] make team snippet more constructive, now that team page is

RESOLVED FIXED in 2.1

Status

Webtools
Elmo
P2
normal
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Pike, Assigned: peterbe)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Now that we've done a bit jump for the team page, we should make bugs more prominent. I'll do some short experiments to gather feedback on.
(Reporter)

Comment 1

6 years ago
Published the initial step at https://github.com/Pike/elmo/compare/develop...feature%2Fbug-718980-bugsy-team-snippet.

Changes: I reworded the heading and the intro blurb to add a tad of context. And I show the ID, summary, last change date and creation date for the most recent 5 open bugs.

I didn't do any HTML styling on that yet. Mostly because it's hard to tell how things look once the design lands, and because I would like to re-use the styles for the tables from the shipping snippet. But for that, we'd had to rename/add classes there, so I wanted feedback on that from peterbe.

So, peterbe, should we make the styling more generic for the tables?

And Jeff, comments on the copy here?
(Assignee)

Comment 2

6 years ago
I like it! There are a couple of things I'd like to improve/change so please go ahead and make a patch and I'll try it out and review.
(In reply to Axel Hecht [:Pike] from comment #1)
> Published the initial step at
> https://github.com/Pike/elmo/compare/develop...feature%2Fbug-718980-bugsy-
> team-snippet.
> 
> Changes: I reworded the heading and the intro blurb to add a tad of context.
> And I show the ID, summary, last change date and creation date for the most
> recent 5 open bugs.
> 
> I didn't do any HTML styling on that yet. Mostly because it's hard to tell
> how things look once the design lands, and because I would like to re-use
> the styles for the tables from the shipping snippet. But for that, we'd had
> to rename/add classes there, so I wanted feedback on that from peterbe.
> 
> So, peterbe, should we make the styling more generic for the tables?
> 
> And Jeff, comments on the copy here?

Copy looks great to me. Short, sweet, and to the point. And yes, I did just say that something you wrote was sweet ;-)
(Assignee)

Updated

6 years ago
Assignee: l10n → peterbe
(Assignee)

Updated

6 years ago
Priority: -- → P2
(Assignee)

Comment 4

6 years ago
Created attachment 593123 [details] [diff] [review]
BugPuller

I took your branch and revamped it a bit.
* Added "Please wait..." loading whilst waiting for the AJAX calls
* An error catcher that shows and excuse (you can run `BugPuller.excuse()` in the Web Console)
* Tidied up the code a bit

You can see my branch in action here:
https://github.com/peterbe/elmo/compare/develop...feature%2Fbug-718980-bugsy-team-snippet
Attachment #593123 - Flags: review?(l10n)
(Reporter)

Comment 5

6 years ago
Comment on attachment 593123 [details] [diff] [review]
BugPuller

I like what you did to the code here, r=me.
Attachment #593123 - Flags: review?(l10n) → review+
(Assignee)

Comment 6

6 years ago
https://github.com/mozilla/elmo/commit/32b33eb51eea873d6f71e438e42753a851633a28
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

6 years ago
Actually some "regression". We ought to insert some timeout callbacks. Right now, when I'm testing, it's not failing simply because it's allowed to take a loooong time.
(Assignee)

Comment 8

6 years ago
(In reply to Peter Bengtsson [:peterbe] from comment #7)
> Actually some "regression". We ought to insert some timeout callbacks. Right
> now, when I'm testing, it's not failing simply because it's allowed to take
> a loooong time.

I take it back. It's working just fine. It's just that the bugzilla.mozilla.org server is configured for very very long read time-outs. We shouldn't be opinionated in the AJAX and just let bugzilla time out when it needs to time out.
(Reporter)

Updated

6 years ago
Target Milestone: --- → 2.1
You need to log in before you can comment on or make changes to this bug.