Flash plugins are not clipped by iframe boundary

RESOLVED WONTFIX

Status

P3
normal
RESOLVED WONTFIX
7 years ago
2 months ago

People

(Reporter: martijn.martijn, Assigned: snorp)

Tracking

(Blocks: 1 bug, {testcase})

Trunk
ARM
Android
testcase
Dependency tree / graph

Details

(URL)

(Reporter)

Description

7 years ago
Tested on the LG Optimus Black, using Android 2.2.2.

Steps to reproduce:
Tap on one of "Tap here to activate plugin" placeholders on the testcase

Expected result:
- Flash plugins appear and they should be clipped by the blue bordered iframes

Actual result:
- The Flash plugins are not clipped by the blue bordered iframes
Assignee: nobody → snorp
tracking-fennec: --- → 11+
Priority: -- → P3
It's simply not possible to fix this due to the architecture of plugins on Android. Sorry.

I'll leave this open in case someone thinks of a way to fix it, however.
(Reporter)

Comment 2

7 years ago
I noticed that when scrolling completely to the right, the Flash plugins from the left iframe are still painted on the screen, even though they are scrolled outside the view of the screen.
That's also clearly a bug (that perhaps is easy to fix?). Should I file a new bug for that?
(Reporter)

Comment 3

7 years ago
Hi, should I file a new bug for the issue I mentioned in comment 2?
(In reply to Martijn Wargers [:mw22] (QA - IRC nick: mw22) from comment #3)
> Hi, should I file a new bug for the issue I mentioned in comment 2?

That actually should be fixed now as part of the fix for bug 721741. If you see it in tomorrow's nightly, though, there might still be a problem.
(Reporter)

Updated

7 years ago
Depends on: 721741
Duplicate of this bug: 724836
I think we see this also when we double tap to zoom with a flash on page.  Is that a different bug than this?
(Reporter)

Comment 7

7 years ago
I don't think so, afaik.
(Reporter)

Updated

6 years ago
Blocks: 757323
Component: General → Plugins
tracking-fennec: 11+ → -
This is ok now on ICS and Honeycomb, but we can't fix for Gingerbread and earlier.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX

Updated

2 months ago
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.