mozilla gets stuck downloading a page from nytimes.com

VERIFIED WORKSFORME

Status

()

--
major
VERIFIED WORKSFORME
18 years ago
16 years ago

People

(Reporter: dmosberger, Assigned: neeti)

Tracking

Trunk
mozilla1.0
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: worksforme?, URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.0-test12 i586)
BuildID:    2001021712

Occasinally, mozilla gets stuck while downloading an article from nytimes.com. 
I'm not sure whether this is triggered by the contents of the article or
something else (restarting mozilla doesn't fix the problem though).  The URL
mentioned above so far reproduces the problem reliably.  I have seen this issue
with other NY Times articles before.

Reproducible: Always
Steps to Reproduce:
1. Just visit the URL.
2.
3.

Actual Results:  Mozilla starts downloading the page.  The progress bar at the
bottom of the browser first proceeds normally and then suddenly starts jumping
backwards.  The download never actually completes (not within the 5 minutes of
patience that I gave it, at least ;-).

Expected Results:  Mozilla shouldn't get stuck downloading the page.

Comment 1

18 years ago
The URL referenced in the bug report no longer exists.
David, I just tried to reproduce this, and after 20 forced reloads with build
2001-04-09-08 on Linux, I cannot reproduce this problem.  Please try a more
recent build?
Whiteboard: worksforme?

Comment 3

18 years ago
I have build 2001032614 (0.8.1) on RedHat Linux 6.2 and it just goes to a page
saying I'm not logged in without any problem.

Comment 4

18 years ago
Marking WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

18 years ago
I played with this some more and found that the real culprit to be the
following: when accessing the URL, the server attempts to set (or update) a
cookie (assuming you're a registered user).  Now, in my case, mozilla was
accidentically set up to reject cookies from nytimes.com.  After using the
cookie manager to remove the entry that prevented nytimes.com from setting a
cookie, it all works fine now.

While this problem was due to my own doing, I still think there is a bug in
Mozilla: it should never get stuck downloading a page in this fashion.  There
should be a more graceful way of handling the problem (e.g., an "access denied"
page would be fine).
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 6

18 years ago
over to cookies
Assignee: asa → morse
Status: UNCONFIRMED → NEW
Component: Browser-General → Cookies
Ever confirmed: true
QA Contact: doronr → tever

Comment 7

18 years ago
From the description, this is not a cookie problem.  If we never finish 
downloading a page, its more likely a networking problem having nothing to do 
with the fact that we are rejecting cookies for the particular site.
Assignee: morse → neeti
Component: Cookies → Networking
(Assignee)

Updated

18 years ago
Target Milestone: --- → mozilla1.0

Comment 8

18 years ago
mass move, v2.
qa to me.
QA Contact: tever → benc

Comment 9

17 years ago
current CVS, linux: WFM
Page loads and finishes loading.

I then set cookie  manager to block cookies from that site, deleted cache, and
loaded the page again:
Page still loaded OK and finished loading.

Comment 10

17 years ago
reopen if you see this again. 
Status: NEW → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 11

16 years ago
VERIFIED: wfm, phoenix 0.4
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.