Last Comment Bug 719021 - Saving an empty new style sheet does not display the file name upon saving
: Saving an empty new style sheet does not display the file name upon saving
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Style Editor (show other bugs)
: 11 Branch
: x86 Linux
: -- normal (vote)
: Firefox 12
Assigned To: Cedric Vivier [:cedricv]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-18 06:52 PST by Alex Lakatos[:AlexLakatos]
Modified: 2012-01-27 05:28 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch v1 (2.93 KB, patch)
2012-01-25 07:59 PST, Cedric Vivier [:cedricv]
paul: review+
Details | Diff | Splinter Review

Description Alex Lakatos[:AlexLakatos] 2012-01-18 06:52:59 PST
A new stylesheet will continue to show the same "New style sheet #No" name until the show/hide button is triggered.

Steps to Reproduce:
1.Open the Style Editor
2.Add a new stylesheet
3.Save it

Expected Results:
4.The name displayed in the stylesheet list is changed

Actual Results:
4.The name displayed in the stylesheet list is changed only after the show/hide button is triggered.
Comment 1 Paul Rouget [:paul] 2012-01-23 09:34:41 PST
I think this is the expected behavior. Saving the stylesheet doesn't change its URL in the page. For example, if you change the local file with another editor, that won't change the style of the page.

Maybe we want to add it's local name between brackets.

Cedric?
Comment 2 Alex Lakatos[:AlexLakatos] 2012-01-23 09:38:29 PST
(In reply to Paul Rouget [:paul] from comment #1)
> I think this is the expected behavior. Saving the stylesheet doesn't change
> its URL in the page. For example, if you change the local file with another
> editor, that won't change the style of the page.
This happens for newly created style sheets by the user. Pressing the show/hide icon changes the displayed name. I think it's confusing that after "save" is hit for a newly created style sheet it does not change the displayed name in the list.
Comment 3 Paul Rouget [:paul] 2012-01-23 09:43:29 PST
Sorry. You were talking about a New Style. I missed that. You're right.
Comment 4 Paul Rouget [:paul] 2012-01-23 10:24:09 PST
I can't reproduce :(
Comment 5 Alex Lakatos[:AlexLakatos] 2012-01-24 02:27:26 PST
I can reproduce across platforms for both Aurora(11a2) and Nightly(12a1). 
Here is a screencast reproducing the issue with today's Nightly on Linux: http://dl.dropbox.com/u/22633148/bug719021.ogv
Comment 6 Paul Rouget [:paul] 2012-01-24 10:25:47 PST
So apparently, this happens only if the stylesheet is empty. Cedric, can you take a look at this?
Comment 7 Cedric Vivier [:cedricv] 2012-01-25 03:12:30 PST
(In reply to Paul Rouget [:paul] from comment #6)
> So apparently, this happens only if the stylesheet is empty. Cedric, can you
> take a look at this?

I can reproduce. This only happens when saving a completely empty style sheet.
Comment 8 Cedric Vivier [:cedricv] 2012-01-25 07:59:54 PST
Created attachment 591469 [details] [diff] [review]
patch v1
Comment 9 Paul Rouget [:paul] 2012-01-26 06:43:18 PST
https://hg.mozilla.org/integration/fx-team/rev/7571ade2acbf
Comment 10 Tim Taubert [:ttaubert] (on PTO, back Aug 29th) 2012-01-27 02:27:46 PST
https://hg.mozilla.org/mozilla-central/rev/7571ade2acbf

Note You need to log in before you can comment on or make changes to this bug.