MIPSpro 7.3.1.2m Seg Faults after configure --disable-debug

VERIFIED FIXED in mozilla0.9

Status

()

P4
critical
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: jayvdb, Assigned: waterson)

Tracking

({helpwanted})

Trunk
mozilla0.9
SGI
IRIX
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Building releases M18 - 0.8 and nightly, configure --disable-debug causes the 
MIPSpro 7.3.1.2m compiler to seg fault in Code_Expansion phase (signal 4) on 
each of the following files

layout/base/src/nsPresContext.cpp
layout/html/base/src/nsObjectFrame.cpp
layout/html/document/src/nsHTMLContentSink.cpp or 
content/html/document/src/nsHTMLContentSink.cpp

Initial investigation shows NS_CheckContentLoadPolicy is common between these 
files, and I was able to get nsHTMLContentSink.cpp to compile by removing the 
lines around NS_CheckContentLoadPolicy (Mozilla then core dumped in an un-
related section)
http://lxr.mozilla.org/seamonkey/ident?i=NS_CheckContentLoadPolicy
(Reporter)

Comment 1

18 years ago
Created attachment 27672 [details] [diff] [review]
While not cross-platform; this diff does allow --disable-debug to compile on IRIX

Updated

18 years ago
Summary: MIPSpro 7.3.1.2m Seg Faults after configure --disable-debug → MIPSpro 7.3.1.2m Seg Faults after configure --disable-debug

Comment 2

18 years ago
Removing the PR_BEGIN/END macros sounds like a Bad Idea (tm).  Reassigning to
the layout team . cc'ing scc for advice on potential compiler funkiness and
cc'ing shaver as lxr claims he last touched that macro.

Assignee: cls → karnaze
Status: UNCONFIRMED → NEW
Component: Build Config → Layout
Ever confirmed: true
QA Contact: granrose → petersen

Comment 3

18 years ago
Reassigning to waterson and moving to m0.9.1
Assignee: karnaze → waterson
Target Milestone: --- → mozilla0.9.1
(Assignee)

Comment 4

18 years ago
cls is right: removing the PR_[BEGIN|END]_MACRO stuff is bad: it declares a 
local variable. Since I don't have access to this wonderful compiler, I can't 
really explore other alternatives. heikki: do you have any ideas?
Keywords: helpwanted
Priority: -- → P4
Target Milestone: mozilla0.9.1 → Future
Not sure why I was Cc:d. I don't know of that compiler, and the code isn't
exactly my area either.

But, to me it looks like in this case it would be pretty safe to remove the
PR_BEGIN|END macros because the CHECK_CONTENT_POLICY macro is only used inside
NS_CheckContentLoadPolicy and NS_CheckContentProcessPolicy functions in file
nsContentPolicyUtils.h, and at the end of the file CHECK_CONTENT_POLICY is
undefined so you can't even use it anywhere else.

(Assignee)

Comment 6

18 years ago
Ok, then. Let's do it. shaver? r=?
Just hand-expand that macro in the two functions, and let's get on with our lives.
(Reporter)

Updated

18 years ago
Blocks: 73732
(Assignee)

Comment 8

18 years ago
i'll check it in as soon as I get a sane tree.
Status: NEW → ASSIGNED
Target Milestone: Future → mozilla0.9
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

18 years ago
Fixed.

Comment 10

18 years ago
Marking verified per last comments
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.