firefox is using non valid way to clear cache

RESOLVED INVALID

Status

()

RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: benapetr, Unassigned)

Tracking

9 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111220165912

Steps to reproduce:

Refreshed a page


Actual results:

It sent a max-age=0 to cache proxy


Expected results:

It should send Pragma: no-cache more details in original report - this bug is old more than 10 years and still not resolved
http://archives.lists.indymedia.org/imc-tech/2001-October/005697.html
bug 419194 could be related
Component: Untriaged → Networking
Product: Firefox → Core
QA Contact: untriaged → networking
The url you link to is a complaint that a purposefully-not-spec-compliant proxy is not behaving "as expected" because its not spec-incompliant enough, as far as I can tell.

So what is this bug about, exactly?  On a reload, we _don't_ want to prohibit intermediate caching; we just want to make sure we get updated content, but we don't mind if intermediate proxies cache it.  That's exactly what "max-age=0" should do in a spec-compliant proxy.
And in fact, based on the summary, this bug is just invalide.  sending "max-age=0" as a way to request up-to-date content is what the spec says to do.  We are NOT trying to "clear cache".
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.