Rename "Reload Remote Calendar" to "Synchronize Calendars"

RESOLVED FIXED in 1.3

Status

RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Fallen, Assigned: Fallen)

Tracking

Dependency tree / graph

Details

Attachments

(1 attachment)

With tabs on top we now have a "Synchronzize" toolbar button. Since the reload remote calendars button really just does a reload of everything, I think we should put these in line.

This should be seen as part of the tabs on top patch, I will likely land this on aurora too.
(Assignee)

Updated

7 years ago
Blocks: 719198
Created attachment 589622 [details] [diff] [review]
Fix - v1

I've taken the liberty to also include a change for filter.py to ignore sunbird strings, since there was also a reload remote calendars string in there.
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #589622 - Flags: review?(richard.marti)
If "the reload remote calendars button really just does a reload of everything" as you said than "Reload" is a way better name than "Synchronize" and should stay.
Since we already have an icon for synchronize I'd like to avoid renaming it to reload now. Although you will rightfully say that we haven't done this yet, the goal is to move towards a fast and stable enough storage provider so that the cache can be default, which would make synchronize correct again.
Comment on attachment 589622 [details] [diff] [review]
Fix - v1

Review of attachment 589622 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. I haven't checked if filter.py works but trust your skills ;)

-<!ENTITY calendar.reloadserver.label                       "Reload Remote Calendars">
-<!ENTITY calendar.reloadserver.key                         "R">
-<!ENTITY calendar.reloadserver.accesskey                   "R">
+<!ENTITY calendar.synccalendars.label                       "Synchronize Calendars">
+<!ENTITY calendar.synccalendars.key                         "R">
+<!ENTITY calendar.synccalendars.accesskey                   "S">

This three strings have a space too much so they are not well aligned.

r+ with this nit fixed.
Attachment #589622 - Flags: review?(richard.marti) → review+
(In reply to Philipp Kewisch [:Fallen] from comment #5)
> comm-central changeset 120cf812400a
> releases/comm-aurora changeset e8df1f3d2202

Can this bug report be marked reolved?
OS: Mac OS X → All
Hardware: x86 → All
Yes, looks like I just forgot to close it :)
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Duplicate of this bug: 395890
You need to log in before you can comment on or make changes to this bug.