keyboard doesn't work in any popup window under VTWM

VERIFIED DUPLICATE of bug 78928

Status

()

--
major
VERIFIED DUPLICATE of bug 78928
18 years ago
18 years ago

People

(Reporter: rohan.hart, Assigned: trudelle)

Tracking

({relnote})

Trunk
mozilla0.9.2
SGI
IRIX
relnote
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; IRIX 6.5 IP32; en-US; 0.8.1) Gecko/20010312
BuildID:    2001031221

This is similar in behaviour to 70742, ie. text can not be entered into any of
the text fields, except that it affects all popup windows such as "find",
"save", "preferences", etc. Note that the field does appear to gain focus and
text can be pasted into fields using the mouse. Other keys such as enter and
backspace also have no affect.

A build around 200101something didn't display this problem and fields in the
browser such as location never have this problem.

Reproducible: Always
Steps to Reproduce:
1.open find using menu or Ctrl-F
2.select "find text" field
3.type away

Actual Results:  No text appears in the field

Expected Results:  Text should have appeared
most likely a duplicate of bug 71836.  Could you please try a new build and see
whether it's fixed?
(Reporter)

Comment 2

18 years ago
It's still occuring in the latest IRIX build 2001031521
(Reporter)

Comment 3

18 years ago
Discovered the problem!  I'm using VTWM 5.4.5 and wasn't decorating transient
windows (the default), ie. they have no titlebar.  Turning on the title bar
makes them work again.

I can't recall whether the last working browser version used transients for the
popups or not.  Either way it's strange because the popups do gain focus, just
not text focus when not decorated.

Comment 4

18 years ago
Possible release note fodder.
Keywords: relnote

Comment 5

18 years ago
CCing endico for possible release note comment.
see also bug 76854 and bug 73727.

ccing blizzard

Comment 7

18 years ago
this bug is listed in the release notes, it deserves to be marked new.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Is this IRIX only, or does it happen on Linux as well?
Keywords: nsCatFood
Target Milestone: --- → mozilla0.9.2
Can the reporter try a build that is from tomorrow or a 0.9 build from the tree?
 This might have been licked.  This only appears to happen when the WM isn't
used for focus handling for transient windows.
(Reporter)

Comment 10

18 years ago
It's still happening with build 2001050421
(Reporter)

Comment 11

18 years ago
The release notes say "When using VTMW 5.4.5, transient windows must be turned
on for popup menus to function" which isn't quite correct. Try this instead:

  When using VTMW 5.4.5, transient windows must be decorated (not the default)
for popup windows such as Find, Save and Preferences to function.

Comment 12

18 years ago
In response to Heikki Toivonen 2001-05-03 11:20 comment:
> Is this IRIX only, or does it happen on Linux as well?
 
This is Linux (RH6.1) as well, when using the vtwm window manager (v 5.4.5a).
The same work-around (setting 'DecorateTransients' in the .vtwmrc file) also
works.

[tested with Mozilla 0.9 - Buid ID: 2001050521]

Comment 13

18 years ago
mozilla 0.9 release note item updated with rohan's new text.
(Reporter)

Comment 14

18 years ago
Using build 2001052521 I get similar results to bug 76854 where keyboard focus
works when transients aren't decorated IF the window is explicitly focused by
the WM.

76854 does say that it appears to be fixed - still doesn't work for me

Comment 15

18 years ago
This is obviously a problem at the Unix widget level with a particular window 
manager, not the event subsystem.  This should be handled by a Unix widget guy.  
Not sure who that is, though.
Summary: keyboard doesn't work in any popup window → keyboard doesn't work in any popup window under VTWM

Comment 16

18 years ago
This should be assigned to an X widget guy of some sort.
Assignee: joki → trudelle
Component: Event Handling → XP Toolkit/Widgets
QA Contact: gerardok → aegis
(Assignee)

Comment 17

18 years ago

*** This bug has been marked as a duplicate of 78928 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 18

18 years ago
verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.