Last Comment Bug 719273 - Make the TLS windows code more includeable
: Make the TLS windows code more includeable
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: General (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla12
Assigned To: Jeff Muizelaar [:jrmuizel]
:
:
Mentors:
: 719134 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-18 16:18 PST by Jeff Muizelaar [:jrmuizel]
Modified: 2012-01-19 10:51 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Avoid including windows header files when we can (1.82 KB, patch)
2012-01-18 16:21 PST, Jeff Muizelaar [:jrmuizel]
ehsan: review+
Details | Diff | Splinter Review

Description Jeff Muizelaar [:jrmuizel] 2012-01-18 16:18:58 PST

    
Comment 1 Jeff Muizelaar [:jrmuizel] 2012-01-18 16:21:19 PST
Created attachment 589696 [details] [diff] [review]
Avoid including windows header files when we can

The windows headers do inconvenient things like:
#define CreateEvent CreateEventW

We'd like to avoid this.
Comment 2 :Ehsan Akhgari 2012-01-18 16:56:05 PST
Comment on attachment 589696 [details] [diff] [review]
Avoid including windows header files when we can

r=me.
Comment 3 :Ehsan Akhgari 2012-01-18 16:56:54 PST
*** Bug 719134 has been marked as a duplicate of this bug. ***
Comment 4 Matt Brubeck (:mbrubeck) 2012-01-19 10:51:57 PST
https://hg.mozilla.org/mozilla-central/rev/2cfe51d20cce

Note You need to log in before you can comment on or make changes to this bug.