Closed Bug 719307 Opened 8 years ago Closed 4 years ago

"move to group" tab context menu item is super slow to load sometimes

Categories

(Firefox Graveyard :: Panorama, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: dietrich, Unassigned)

Details

(Whiteboard: [snappy:p3])

sometimes nothing will happen for several seconds, then the menu finally pops open.
Whiteboard: [snappy]
Whiteboard: [snappy] → [snappy:p4]
I keep accidentally using a non-existent snappy:p4 priority
Whiteboard: [snappy:p4] → [snappy:p3]
I can repro this on the first usage of the sub-menu after every startup.
I can confirm it takes multiple seconds on a fairly fast machine.
Panorama has been removed from Firefox 45, currently in Beta and scheduled for release on March 7th. As such, I'm closing all existing Panorama bugs.

If you are still using Panorama, you will see a deprecation message in Firefox 44, and when 45 is released your tab group data will be migrated to bookmarks, with a folder for each group. There are also a few addons offering similar functionality.

See https://support.mozilla.org/en-US/kb/tab-groups-removal for more info.

We're removing Panorama because it has extremely low usage (about 0.01% of users), and has a large number of bugs and usability issues. The cost of fixing all those issues is far too high to justify, and so we'll instead be focusing our time and energy on improving other parts of Firefox.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.