Last Comment Bug 719309 - Disable touch events widget code
: Disable touch events widget code
Status: RESOLVED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 12
Assigned To: Wesley Johnston (:wesj)
:
: Sebastian Kaspari (:sebastian)
Mentors:
Depends on:
Blocks: 603008
  Show dependency treegraph
 
Reported: 2012-01-18 18:34 PST by Wesley Johnston (:wesj)
Modified: 2012-02-09 16:07 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-
fixed


Attachments
Patch (5.82 KB, patch)
2012-01-18 18:34 PST, Wesley Johnston (:wesj)
mark.finkle: review+
doug.turner: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Wesley Johnston (:wesj) 2012-01-18 18:34:25 PST
Created attachment 589749 [details] [diff] [review]
Patch

Touch events are almost ready, but the widget code needs some... tweaking to deal correctly with asynchronous scrolling. To make things a bit easier to work on, we'd like to land them preffed off for now and file individual bugs for follow up work.
Comment 1 Mark Finkle (:mfinkle) (use needinfo?) 2012-01-18 20:49:49 PST
Comment on attachment 589749 [details] [diff] [review]
Patch

"sendTouchEvents" -> "touchEventsEnabled"

* I assume this does not mess up GeckoPreferences gecko listener for Preference:Data
* We should probably remove this code once touch events are working well enough. I don't think we want to keep this capability.
Comment 2 Wesley Johnston (:wesj) 2012-01-24 16:34:29 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/bfa8aedbff44

Just realized I forgot to change this name. I'll push a follow up...
Comment 3 Wesley Johnston (:wesj) 2012-01-24 16:42:04 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/ba99528f5f11 - variable rename
Comment 5 Brad Lassey [:blassey] (use needinfo?) 2012-01-27 23:47:20 PST
Wes, please request aurora approval
Comment 6 Wesley Johnston (:wesj) 2012-01-28 07:14:21 PST
Comment on attachment 589749 [details] [diff] [review]
Patch

User impact if declined: Needed to keep multitouch moving forward
Testing completed (on m-c, etc.): on mc since 1/24
Risk to taking this patch (and alternatives if risky): Low risk. Mobile only. Only disables new code.
Comment 7 Wesley Johnston (:wesj) 2012-02-06 18:29:32 PST
https://hg.mozilla.org/releases/mozilla-beta/rev/f5e015526fde
Comment 8 Wesley Johnston (:wesj) 2012-02-06 18:30:41 PST
https://hg.mozilla.org/releases/mozilla-beta/rev/fffeb5ffd845

Note You need to log in before you can comment on or make changes to this bug.