Can't use the Junk button to mark mail as junk

RESOLVED INVALID

Status

Thunderbird
Message Reader UI
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: Hadmut Danisch, Unassigned)

Tracking

8 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Ubuntu; X11; Linux x86_64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111228084940

Steps to reproduce:

Hi, 

some time ago (when thunderbird had the better user interface), it was possible to select multiple mail messages at once and set the Junk status to Junk or Non-Junk collectively with a single mouse click. 

Now the user interface became bulky and unergonomic. Now you need to select every single message with the mouse and set it's junk status one at a time, moving the mouse up and down. cumbersome, annyoing, time-consuming.


Actual results:

What happened? Once upon a time thunderbird had a really good, ergonomic, fast-to-use, and screen-space-econimical user interface. 

Then some moron enforced a new user interface, wasting screen space, breaking search functionality, making the user interface bulky, cumbersome, counter-intuitive, non-ergonomic, unusable on small screens.


Expected results:

What should have happened? Exactly what happened with older thunderbird versions before inventing the new user interface. The old version was just the way it should be. Fast, simple, effective.

What should also have happened? The thunderbird development team should have spent some thoughts about why they are worsening the user interface and ignoring all user complaints.

Comment 1

6 years ago
Select messages, then Message | Mark | As Junk (or simply hit "J") works for me. That doesn't work for you?
(Reporter)

Comment 2

6 years ago
I was guided by the obvious „Junk” button and took that as the intended option. I wasn't aware that the button was made broken by design and a workaround in the menu was made. Especially since the german word „Markieren” was usually used for the color tags, not for the junk state.

Why complicate things? Why is there an obvious junk button if I am expected to use a different way?

Thunderbird once had a much better and more intuitive user interface. I've never understood why they changed the previous user interface (and don't see any benefit in the new one).
Anything in tools -> Error console when this happens ?
Summary: Junk-Status User Interface degraded → Can't use the Junk button to mark mail as junk
(Reporter)

Comment 4

6 years ago
No error message. There's simply no Junk-Button to press once multiple messages are selected.

with earlier versions of thunderbird (>1-2 years ago), the junk button was at the top and not bound to the message, and thus could be pressed any time. 

That new UI design, that had been introduced some time ago, is still confusing and counter-intuitive. Many functions have been made too complicated to be usable.

Comment 5

6 years ago
The junk button is now (since 3.0 i believe) in the message header pane. You can right click the main toolbar to customize and add the junk button if you prefer it like it used to be.

->INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.