Crash after Reload when getComputedStyle(element).SOMETHINGUNDEFINED was called

VERIFIED DUPLICATE of bug 58830

Status

()

Core
DOM: CSS Object Model
VERIFIED DUPLICATE of bug 58830
18 years ago
18 years ago

People

(Reporter: Georg Maaß, Assigned: jst)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
The follwoing test document alerts "undefined", but when you reload the document
after the alert, then Mozilla 0.8 crashes each time displaying a Dr. Watson
window on my NT machine.


<html>
<head>
	<title>getComputedStyle-Test</title>
</head>

<body>
<p id="test1">Absatz</p>
<script>
alert(document.defaultView.getComputedStyle(document.getElementById('test1'),null).nodeName)
</script>
</body>
</html>
(Reporter)

Comment 1

18 years ago
This displays the values after onload. When tryin to unload the page, it also
crashes.


<html>
<head>
	<title>getComputedStyle-Test</title>
</head>

<body>
<p id="test1">Absatz</p>
<script>
e=document.defaultView.getComputedStyle(document.getElementById('test1'),null);
if(e) onload = init
function init()
{
	alert('width: '+e.getPropertyValue('width')+'\nheight:
'+e.getPropertyValue('height'))
}
</script>
</body>
</html>
Duplicate of bug 58830 ("PresShell/ViewManager ownership model needs to be
cleaned up.") via bug 63308 ("Crash on reload after calling getComputedStyle")

*** This bug has been marked as a duplicate of 58830 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
dang you beat me to it again :-)
VERIFIED dup
Status: RESOLVED → VERIFIED
(Assignee)

Comment 4

18 years ago
This was fixed a few weeks ago, btw...
You need to log in before you can comment on or make changes to this bug.