If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Invalid URL's added to history list

VERIFIED DUPLICATE of bug 9203

Status

()

Core
Document Navigation
VERIFIED DUPLICATE of bug 9203
17 years ago
9 years ago

People

(Reporter: Brian Sea, Assigned: Alec Flett)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.1-ac19 i686; en-US; 0.9) Gecko/20010305
BuildID:    2001030508( nightly from 20010312 )

When an invalid URL is entered in the "Location" box, then it is added to the
history list.  This causes autocompletion to 
autocomplete on an invalid URL.

Reproducible: Always
Steps to Reproduce:
1) Enter an invalid URL and press Enter.
2) Start entering it again, and autocomplete to it.

Actual Results:  Autocompletes to an invalid URL

Expected Results:  The invalid URL should not be added to the history.  

Perhaps adding to the history should wait until *after* the contacting of the
remote server is complete, or until 
after Mozilla is sure that the remote server exists and the URL is valid.

Updated

17 years ago
Component: History: Global → History: Session
Keywords: qawanted
Whiteboard: DUPEME
(Assignee)

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 9203 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
vrfy
Status: RESOLVED → VERIFIED
Keywords: qawanted
Whiteboard: DUPEME

Updated

9 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.