Last Comment Bug 719433 - IonMonkey: enable SETPROP PIC/stubs for ARM
: IonMonkey: enable SETPROP PIC/stubs for ARM
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: general
:
:
Mentors:
Depends on:
Blocks: 713526
  Show dependency treegraph
 
Reported: 2012-01-19 07:34 PST by Brian Hackett (:bhackett)
Modified: 2012-03-16 16:28 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
/home/mrosenberg/patches/addSetProp-r0.patch (11.13 KB, patch)
2012-02-17 20:03 PST, Marty Rosenberg [:mjrosenb]
bhackett1024: review+
Details | Diff | Splinter Review

Description Brian Hackett (:bhackett) 2012-01-19 07:34:35 PST
Bug 713526 aborts on encountering SETPROP in ARM due to some not yet implemented assembler bits.
Comment 1 Marty Rosenberg [:mjrosenb] 2012-02-17 20:03:30 PST
Created attachment 598484 [details] [diff] [review]
/home/mrosenberg/patches/addSetProp-r0.patch

Most of this patch was fixing the types of the setprop functions, since callvm does not work with Values at all on arm, and in general, should not pass values by value.
Comment 2 Brian Hackett (:bhackett) 2012-02-23 13:54:40 PST
Comment on attachment 598484 [details] [diff] [review]
/home/mrosenberg/patches/addSetProp-r0.patch

Review of attachment 598484 [details] [diff] [review]:
-----------------------------------------------------------------

::: js/src/ion/shared/CodeGenerator-shared.cpp
@@ +380,5 @@
>          // it returns.
>          argumentPadding = (fun.explicitStackSlots() * sizeof(void *)) % StackAlignment;
>          masm.reserveStack(argumentPadding);
>      }
> +    //masm.breakpoint();

rm
Comment 3 Marty Rosenberg [:mjrosenb] 2012-02-29 05:17:43 PST
landed: http://hg.mozilla.org/projects/ionmonkey/rev/707fcb980e96

Note You need to log in before you can comment on or make changes to this bug.