Sort history old skool. werd.

VERIFIED FIXED in mozilla0.9.3

Status

()

Core
History: Global
P2
normal
VERIFIED FIXED
18 years ago
16 years ago

People

(Reporter: BenB, Assigned: Blake Ross)

Tracking

({helpwanted})

Trunk
mozilla0.9.3
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fix in hand)

(Reporter)

Description

18 years ago
Since recently, the history items are sorted in folders, one for each day.
This is not only completely pointless (you achieve the same by sorting after
Last visited), but prevents me from sorting after title or url across the whole
history. This is one of the major uses of the history for me.
Bug doesn't exist in Mozilla 0.8.
(Reporter)

Updated

18 years ago
Severity: major → normal
Keywords: regression

Updated

18 years ago
Status: NEW → ASSIGNED
Keywords: regression → 4xp
Priority: -- → P2
Summary: Can't sort history iitems by title or location → Sort history old skool. werd.
Target Milestone: --- → mozilla0.9

Comment 1

18 years ago
this isn't a bug or a regression - we changed the way the feature works.
However, I was also planning on adding 2 additional views to history
- group by site (bug 65875)
- No grouping, like the old history.

since I don't have a bug for the "No grouping" option, I'll make this bug for
that.

removing "regression" but adding 4xp, and targeting the same as but 65875

Comment 2

18 years ago
as much as I'd like to fix this in mozilla 0.9, I am overloaded and must push
this back a milestone. Sorry!
Target Milestone: mozilla0.9 → mozilla0.9.1
(Reporter)

Comment 3

18 years ago
:-) np.

Comment 4

18 years ago
*** Bug 74895 has been marked as a duplicate of this bug. ***

Comment 5

18 years ago
use it continuously (I very rarely use IE so don't have a big history list in IE
- so it wasn't until it appeared in Mozilla that I used it a lot) I've decided
that the old mozilla/netscape style is better for me. Nominating for 1.0 as I
believe this really should be re-implemented before 1.0 as many people are used
to it. Possibly a nsCatFood nominee as cats that are used to Netscape may not
like the taste of the new history :)

I know the target milestone is for 0.9.1 but I'm setting this just incase Alec
is too busy to implement this by the target and has to move this back further. I
can cope with IE style history during these pre-releases but it'd be a shame if
the old style isn't brought back as an option. I'm sure the new style will be
highly popular too, which one to make default is the hard question.

Personally I go for IE style in the sidebar, Netscape style in the separate window
Keywords: mozilla1.0

Comment 6

18 years ago
Don't worry.....and please let's keep advocacy and
reasons-this-bug-should-be-fixed out of bugs - I know how important this is to
people, I really want to fix it and will try the best I can to get it in for moz
0.9.1... you don't have to convince me any more!
nav triage: in light of Alec's other deliverables for mozilla0.9.1, moving this
out to mozilla1.0. 
Target Milestone: mozilla0.9.1 → mozilla1.0

Comment 8

17 years ago
Can we have a pref to select the classic or ie-like?

Comment 9

17 years ago
I don't think it would be too hard to get this to work without going to prefs. 
It could be like thread panes in mailnews.  Day would just be a header like
threaded is in newsgroups.  Click on a header and it sorts by that header (old
school).  Click on the Day header, and it threads 'em by day.  

Comment 10

17 years ago
nope, it's not too hard.. I've just got a lot of other things on my plate. 

Personally, I'd like to see the view menu have a submenu like:

Group By > * Day
             Site
             None

where that submenu is a a radio group, and it would remember your setting.

If anyone wants to work on this feel free. It's as simple as changing the ref=
attribute on the <tree> widget to be either:
NC:HistoryByDate (for "Day")
find:groupby=hostname (for "Site")
NC:HistoryRoot (for "None")
Keywords: helpwanted
(Assignee)

Comment 11

17 years ago
Okay, I'll do this then if you're okay with that, Alec.  However, it's not that 
simple -- outliner asserts when trying to change it dynamically.  Haven't 
looked into it yet.
Assignee: alecf → blakeross
Status: ASSIGNED → NEW
Target Milestone: mozilla1.0 → mozilla0.9.2

Comment 12

17 years ago
well, we're not doing the outliner yet...
sounds like if I get to this before you make the outliner switchover, you're
screwed :)
(Assignee)

Comment 13

17 years ago
Good news -- hewitt fixed the outliner crash, so this is back in with the 
landing.
*** Bug 85159 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

17 years ago
Whiteboard: fix in hand
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: mozilla0.9.2 → mozilla0.9.3

Comment 15

17 years ago
Wanted to file a bug on this, took me some time to find it. 

Can someone append something to the title so it's (slightly) easier to find this
bug.

Suggestion:
(Add option to revert to old style, non-hierarchical history)
(Assignee)

Comment 16

17 years ago
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
mass-verifying claudius' Fixed bugs which haven't changed since 2001.12.31.

if you think this particular bug is not fixed, please make sure of the following
before reopening:

a. retest with a *recent* trunk build.
b. query bugzilla to see if there's an existing, open bug (new, reopened,
assigned) that covers your issue.
c. if this does need to be reopened, make sure there are specific steps to
reproduce (unless already provided and up-to-date).

thanks!

[set your search string in mail to "AmbassadorKoshNaranek" to filter out these
messages.]
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.