Last Comment Bug 719492 - Telemetry for time spent in between GCs
: Telemetry for time spent in between GCs
Status: RESOLVED FIXED
[Snappy:P2]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla13
Assigned To: Bill McCloskey (:billm)
:
Mentors:
Depends on: IncrementalGC
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-19 10:33 PST by Andrew McCreight [:mccr8]
Modified: 2012-02-21 07:59 PST (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (3.99 KB, patch)
2012-01-25 18:05 PST, Bill McCloskey (:billm)
continuation: review+
Details | Diff | Splinter Review

Description Andrew McCreight [:mccr8] 2012-01-19 10:33:22 PST
This could help us find scheduling regressions.
Comment 1 Andrew McCreight [:mccr8] 2012-01-25 17:36:25 PST
Bill said he'd do this as part of his incremental GC stuff, as he's already computing things like what % of the time is in the GC.
Comment 2 Andrew McCreight [:mccr8] 2012-01-25 17:39:15 PST
And actually, that undersells what he is already computing a bit.  Here's his comment about what he is computing:

/*
 * MMU (minimum mutator utilization) is a measure of how much garbage collection
 * is affecting the responsiveness of the system. MMU measurements are given
 * with respect to a certain window size. If we report MMU(50ms) = 80%, then
 * that means that, for any 50ms window of time, at least 80% of the window is
 * devoted to the mutator. In other words, the GC is running for at most 20% of
 * the window, or 10ms. The GC can run multiple slices during the 50ms window
 * as long as the total time it spends is at most 10ms.
 */

It looks like he is currently computing MMU(20ms) and MMU(50ms).
Comment 3 Bill McCloskey (:billm) 2012-01-25 18:05:23 PST
Created attachment 591675 [details] [diff] [review]
patch

Here's a patch on top of the incremental GC stuff. I only added MMU(50ms). Our MMU for smaller window sizes is pretty bad even in testing, so it's probably not worth reporting right now.
Comment 4 Andrew McCreight [:mccr8] 2012-01-25 18:10:12 PST
Comment on attachment 591675 [details] [diff] [review]
patch

Review of attachment 591675 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Comment 5 Lawrence Mandel [:lmandel] (use needinfo) 2012-02-16 14:09:15 PST
This was r+ 3 weeks ago. Who can land these new probes?
Comment 6 Bill McCloskey (:billm) 2012-02-16 14:14:44 PST
The patch is based on incremental GC, so it can't land yet. However, I realize that besides the MMU measurement, it would be nice just to know how many seconds ago the last GC was. So maybe I'll do a separate patch for that. It could land right away.
Comment 7 Andrew McCreight [:mccr8] 2012-02-18 10:39:28 PST
Looks like this landed with incremental GC, so I'm marking as fixed.
Comment 8 Lawrence Mandel [:lmandel] (use needinfo) 2012-02-21 07:56:28 PST
The target milestone isn't set. Did this land in time for 12 or 13?

Note You need to log in before you can comment on or make changes to this bug.