Last Comment Bug 719499 - backport 020e61c8efed, 25fe3fddc59e and d377d38a23d3 to aurora
: backport 020e61c8efed, 25fe3fddc59e and d377d38a23d3 to aurora
Status: RESOLVED FIXED
backporting of work in bug 674647 [qa-]
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: 12 Branch
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
:
Mentors:
Depends on:
Blocks: 715337 721575
  Show dependency treegraph
 
Reported: 2012-01-19 10:47 PST by Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
Modified: 2012-02-01 13:40 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
backport 020e61c8efed, 25fe3fddc59e and d377d38a23d3 to aurora (5.84 KB, patch)
2012-01-19 11:09 PST, Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
ted: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-01-19 10:47:57 PST

    
Comment 1 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-01-19 11:09:09 PST
Created attachment 589917 [details] [diff] [review]
backport 020e61c8efed, 25fe3fddc59e and d377d38a23d3 to aurora

With these ported, we should be able to build mozilla-aurora in 10.6 machines and even use the 10.6 SDK if we want to.
Comment 2 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-01-19 11:10:05 PST
https://tbpl.mozilla.org/?tree=Try&rev=5c908938979d
Comment 3 Ted Mielczarek [:ted.mielczarek] 2012-01-23 13:05:48 PST
Comment on attachment 589917 [details] [diff] [review]
backport 020e61c8efed, 25fe3fddc59e and d377d38a23d3 to aurora

Review of attachment 589917 [details] [diff] [review]:
-----------------------------------------------------------------

::: js/src/jit-test/tests/basic/testBug597736.js
@@ -1,1 @@
> -function leak_test() {

Why is this in this patch?
Comment 4 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-01-23 14:07:00 PST
> Why is this in this patch?

Unreliable test. See bug 717908 for the details.
Comment 5 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-01-23 14:07:53 PST
Comment on attachment 589917 [details] [diff] [review]
backport 020e61c8efed, 25fe3fddc59e and d377d38a23d3 to aurora

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined:

None. This is a build change so that we can use newer OS X bots.

Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
Comment 6 Alex Keybl [:akeybl] 2012-01-25 18:15:25 PST
Comment on attachment 589917 [details] [diff] [review]
backport 020e61c8efed, 25fe3fddc59e and d377d38a23d3 to aurora

[Triage Comment]
In support of testing - approved for Aurora.
Comment 7 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-01-26 05:39:58 PST
https://tbpl.mozilla.org/?tree=Mozilla-Aurora&rev=9d5ede8cb11a
Comment 8 Justin Wood (:Callek) 2012-01-30 16:52:39 PST
This resolveable now?
Comment 9 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-01-31 01:20:03 PST
Yes, thanks.

Note You need to log in before you can comment on or make changes to this bug.