Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 719543 - GCLI REPL syntax should default to JS code
: GCLI REPL syntax should default to JS code
Status: RESOLVED DUPLICATE of bug 717978
Product: Firefox
Classification: Client Software
Component: Developer Tools: Console (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
: (Unavailable until Nov 1) Brian Grinstead [:bgrins]
Depends on:
  Show dependency treegraph
Reported: 2012-01-19 12:19 PST by Dave Herman [:dherman]
Modified: 2012-01-19 12:28 PST (History)
4 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Description Dave Herman [:dherman] 2012-01-19 12:19:11 PST
The new GCLI in Nightly requires you to prefix JS code with a '{' character. I spent a while trying to figure out how to evaluate the number 3. Non of the following worked:

    { 3
    { 3 }

Whereas the following do:

    { 3; }
    { +3

All REPLs/consoles I've seen in history default to JS code, and provide special REPL commands with a special syntax that is syntactically invalid in the language being evaluated. For example, the Node.js repl would expect


Other REPL's I've seen use a colon:


Either way would work fine for JS, since they're both syntactically invalid ways to start the Program non-terminal.

Having new special commands in the console is great, but it's got the defaults wrong.

Comment 1 Andreas Gal :gal 2012-01-19 12:24:32 PST
This is epically cryptic. We should definitely match what other REPLs like Node do.
Comment 2 Dave Herman [:dherman] 2012-01-19 12:27:57 PST

*** This bug has been marked as a duplicate of bug 717978 ***
Comment 3 Kevin Dangoor 2012-01-19 12:28:19 PST
The current plan is to turn GCLI back off in the Web Console (before the next Aurora). The feedback we've been getting in Nightly has been helpful.

GCLI will come back in a new developer toolbar (bug 717915).

I would point you to the bug to pref off GCLI, but I can't find it at the moment (perhaps it doesn't exist yet).

You can set devtools.gcli.enable to false right now to restore the JS entry behavior.

Note You need to log in before you can comment on or make changes to this bug.