If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Incorrect default font-weight for web fonts

RESOLVED INVALID

Status

()

Core
Graphics: Text
RESOLVED INVALID
6 years ago
4 years ago

People

(Reporter: Rob Yedlin, Unassigned)

Tracking

9 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.75 Safari/535.7

Steps to reproduce:

Loaded Futura Bold Condensed web font from bitsteam at myfonts.com


Actual results:

The font loaded way too heavy


Expected results:

Every other browser loads the font with default font-weight: normal; Firefox did not.
Please as a testcase.  This should be webpage source that loads and uses the font as an attachment to this bug.
(Reporter)

Comment 2

6 years ago
Created attachment 590040 [details]
Web font to test

Fonts in question
(Reporter)

Comment 3

6 years ago
Disregard attachment.

Here is the css:

@font-face {font-family: 'FuturaBT-BoldCondensed';src: url('webfonts/futura/eot/style_610.eot?#iefix') format('embedded-opentype'),url('webfonts/futura/woff/style_610.woff') format('woff'),url('webfonts/futura/ttf/style_610.ttf') format('truetype'),url('webfonts/futura/svg/style_610.svg#FuturaBT-BoldCondensed') format('svg'); }
(Reporter)

Comment 4

6 years ago
Created attachment 590041 [details]
Firefox 9 font-weight: normal; not set
(Reporter)

Comment 5

6 years ago
Created attachment 590042 [details]
Chrome font-weight: normal; not set
(Reporter)

Comment 6

6 years ago
Created attachment 590043 [details]
Firefox 9 font-weight: normal; set
Attachment #590040 - Attachment is obsolete: true
Are we applying synthetic bolding in this case because the @font-face rule didn't say the font was bold, but the style using the font asked for bold?

Or is this a Mac-specific rendering issue?


In any case, an HTML testcase is needed to tell (not just a tiny piece of the CSS).
Component: Untriaged → Graphics: Text
Product: Firefox → Core
(In reply to David Baron [:dbaron] (don't cc:, use needinfo? instead) from comment #7)
> Are we applying synthetic bolding in this case because the @font-face rule
> didn't say the font was bold, but the style using the font asked for bold?
> 
> Or is this a Mac-specific rendering issue?
> 
> 
> In any case, an HTML testcase is needed to tell (not just a tiny piece of
> the CSS).

Note that the @font-face rule mentioned in comment 3 does *not* declare the font-weight descriptor, so it will default to normal (400). But the "problem" elements in the screenshot are all headings, so they're almost certainly styled with font-weight:bold.

So I'm virtually certain it's (correct) application of synthetic bold, due to lack of the appropriate font-weight descriptor.

Comment 9

4 years ago
This may also be that the author prefers one form of synthetic bolding to another (Chrome vs. Safari vs. Gecko).  The right solution is to use the appropriate bold face.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.