block-element boxes with fixed width are not horisontally contained inside body box

RESOLVED INVALID

Status

()

Core
CSS Parsing and Computation
RESOLVED INVALID
18 years ago
17 years ago

People

(Reporter: Alexey Chernyak, Assigned: Pierre Saslawsky)

Tracking

({testcase})

Trunk
x86
Windows 2000
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
OS: Win2K
Build: 2001031320

table and caption boxes with fixed width are not contained within body box when
window size is squeesed horisontally.
table and caption boxes go out beyond body box borders.

It also seems that when centered, caption and table positions are calculated
differently. table left border is always contained within body box, while
caption left border isn't, which leads to table and caption being misaligned
relatively each other.

Interestingly window scrollbars react to table box size, not body box size.

Expected result: when window is sized down horisontally, body box stays wide
enough to contain the table and caption boxes, the same way it does when sized
dowh vertically.

Actual result: it doesn't.
(Reporter)

Comment 1

18 years ago
Created attachment 27695 [details]
testcase
(Reporter)

Comment 2

18 years ago
Created attachment 27696 [details]
screenshot
(Reporter)

Comment 3

18 years ago
actually this appears to be more of a body problem than tables.
fixed size DIVs are not horisontally contained inside document body either.
So it looks like any block-element with fixed width is affected by this.

Changing summary to be more general.
Guess it also should be changed from HTMLTables component to something else?

However table and caption behaving differently and getting misaligned stays
table-related. Need to spawn another bug?
Keywords: testcase
Summary: table & caption boxes with fixed width are not horisontally contained in body box → block-element boxes with fixed width are not horisontally contained inside body box
Over to style system to have some style QAs look at it.
Component: HTMLTables → Style System
reassign for real
Assignee: karnaze → pierre
QA Contact: chrisd → ian

Comment 6

18 years ago
Confirmed
Platform: PC
OS: Windows 98
Mozilla Build: 2001040904

Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 7

18 years ago
I talked to Ian about this,
It has some relation to Horizontal Block Growth test in his Evil tests suite:
http://www.bath.ac.uk/%7Epy8ieh/internet/eviltests/horizgrowth.html

However, all boxes in that test have fixed width,
in testcase attached, body has no fixed width.

I'm not sure how body should behave.
Should it always have width of the browser window?
It definately doesn't behave that way vertically.
Body height can be smaller than the window,
and it can be higher than the window to accomodate it's contents.
I think it should behave the same way horisontally.
Keywords: qawanted
This is per CSS. According to CSS, 'height:auto' means 'size to fit your
children' and 'width:auto' means 'size to fit your parent' which in this case
is UA-defined and we use the viewport.

That's a simplified explanation but it's basically it.

Marking INVALID per my comments. If you disagree, please reopen, thanks!
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Keywords: qawanted
Resolution: --- → INVALID
I resolved; qa to petersen
QA Contact: ian → petersen
You need to log in before you can comment on or make changes to this bug.