Greasemonkey should be bundled by default, to keep up with Chrome

RESOLVED DUPLICATE of bug 89016

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 89016
6 years ago
6 years ago

People

(Reporter: Joey Twiddle, Unassigned)

Tracking

10 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:10.0) Gecko/20100101 Firefox/10.0
Build ID: 20120111092507

Steps to reproduce:

Tried to install a userscript from userscripts.org.


Actual results:

Got a page showing it's source code.


Expected results:

The userscript should have been installed.  Chromium allows installation of userscripts by default, and it displays them simply as individual extensions.

Userscripts are basically a large pool of mini extensions which are accessible to Chrome users but require an extra step to install on Firefox (namely installing Greasemonkey first).  This is especially sad since Greasemonkey started on Firefox but now Chrome is the browser supporting the userscript scene!

Admittedly userscripts are not subject to Firefox's addons approval process, so any install should be accompanied by a suitable warning.

I suppose alternatively, we could just add all userscripts as experimental addons in the Mozilla addons database, and see which ones are popular enough to be approved.  :}


== Other thoughts on bundling ==

There may be extensions other than Greasemonkey that would be suitable for bundling.  Perhaps the Top 10 most popular?

Maybe some parts of the existing browser could be moved into bundled extensions, such as the Bookmarks Manager, toolbar editor, and printing functionality, so users who don't use them can remove them like other extensions, and reduce their browser footprint!

(bundled = provided with default install)
(Reporter)

Comment 1

6 years ago
229590 talks about bundling plugins
(Reporter)

Comment 2

6 years ago
Part of my justification for this is that:

I feel safer installing a Userscript distributed by a website vendor,

than I do installing an Extension distributed by a website vendor.

I feel safer because Userscripts are sandboxed and have less access to my browser.

Perhaps Mozilla feel they have addressed this by auditing third-party extensions before adding them to the Mozilla Addons site?

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 89016
You need to log in before you can comment on or make changes to this bug.