Last Comment Bug 719731 - Get rid of window mediator's getMostRecentBrowserWindow across Tilt codebase
: Get rid of window mediator's getMostRecentBrowserWindow across Tilt codebase
Status: RESOLVED FIXED
[tilt]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Inspector (show other bugs)
: 12 Branch
: All All
: -- normal (vote)
: Firefox 12
Assigned To: Victor Porof [:vporof][:vp]
:
Mentors:
Depends on: 719049
Blocks: 719732
  Show dependency treegraph
 
Reported: 2012-01-20 00:53 PST by Victor Porof [:vporof][:vp]
Modified: 2012-01-28 06:24 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (19.44 KB, patch)
2012-01-20 03:40 PST, Victor Porof [:vporof][:vp]
rcampbell: review+
Details | Diff | Splinter Review

Description Victor Porof [:vporof][:vp] 2012-01-20 00:53:58 PST
Because it's redundant.
Comment 1 Victor Porof [:vporof][:vp] 2012-01-20 03:40:54 PST
Created attachment 590164 [details] [diff] [review]
v1
Comment 2 Rob Campbell [:rc] (:robcee) 2012-01-23 07:24:21 PST
which bug does this depend on?
Comment 3 Rob Campbell [:rc] (:robcee) 2012-01-27 11:11:05 PST
Comment on attachment 590164 [details] [diff] [review]
v1

+ * @param {Window} aChromeWindow
+ *                 the top-level browser window
+ *
  * @param {Number} the zoom ammount
  */
-TiltUtils.setDocumentZoom = function TU_getDocumentZoom(aZoom) {
-  TiltUtils.getBrowserWindow()
-           .gBrowser.selectedBrowser.markupDocumentViewer.fullZoom = aZoom;
+TiltUtils.setDocumentZoom = function TU_setDocumentZoom(aChromeWindow, aZoom) {
+  aChromeWindow.gBrowser.selectedBrowser.markupDocumentViewer.fullZoom = aZoom;
 };


I thought we were going to do this:
  /**
   * Store page zoom factor.
   */
  computeZoomFactor: function Highlighter_computeZoomFactor() {
    this.zoom =
      this.win.QueryInterface(Components.interfaces.nsIInterfaceRequestor)
      .getInterface(Components.interfaces.nsIDOMWindowUtils)
      .screenPixelsPerCSSPixel;
  },

for that.

I bet that's in another patch, isn't it.
Comment 4 Victor Porof [:vporof][:vp] 2012-01-27 11:37:13 PST
(In reply to Rob Campbell [:rc] (robcee) from comment #3)
> I bet that's in another patch, isn't it.

Yup, bug 719877.
Comment 5 Rob Campbell [:rc] (:robcee) 2012-01-27 12:54:47 PST
https://hg.mozilla.org/integration/fx-team/rev/e4216a369836
Comment 6 Tim Taubert [:ttaubert] (on PTO, back Aug 29th) 2012-01-28 06:24:44 PST
https://hg.mozilla.org/mozilla-central/rev/e4216a369836

Note You need to log in before you can comment on or make changes to this bug.