Second (optional) parameter for getComputedStyle is required

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
7 years ago
7 years ago

People

(Reporter: ellis.birt, Unassigned)

Tracking

Trunk
x86_64
Windows 7

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.75 Safari/535.7

Steps to reproduce:

Developed a web page that uses getComputedStyle, but omits pseudoElt parameter as documented in mozdev, tested in Firefox, Chrome, Safari, opera and IE on Windows and MacOs 


Actual results:

worked fine in all other browsers, but in camino, did not work.  Eventually tracked down to an error because pseudoElt was omitted.


Expected results:

While section 2.2.1 of the DOM Level2 document does not actually say that the parameter is optional, all major browsers accept its omission so Camino really should follow suit - especially with its lack of Javascript debugging capabilities

Comment 1

7 years ago
See the "Note" section on https://developer.mozilla.org/en/DOM/window.getComputedStyle

Camino 2.1, like Firefox 3.6, uses Gecko 1.9.2, which is < 2.0

Since Gecko 2 does not support embedding, Camino can't use a version of Gecko with this fix.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX

Comment 2

7 years ago
> worked fine in all other browsers

I should mention that by the last numbers I saw, something like 15% of Firefox users are still on 3.6 (since it's currently the most recent long-term-support release), so if you are trying to maximize compatibility of your site you should really be including Firefox 3.6 in your test matrix (it certainly has orders of magnitude more users than Camino). And fixing issues for Firefox 3.6 will take care of Camino 2.1 in almost every case.
You need to log in before you can comment on or make changes to this bug.