Renamed bookmark not remembered

VERIFIED FIXED

Status

SeaMonkey
Bookmarks & History
VERIFIED FIXED
17 years ago
7 years ago

People

(Reporter: Becki Sanford, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({dataloss})

Trunk
x86
Linux
dataloss

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; U; Linux 2.4.0-test10 i686)
BuildID:    Mozilla 0.8 and nightly 20010310810

Changes to bookmark names are only remembered if the browser window is still
open.

Reproducible: Always
Steps to Reproduce:
1.Launch browser
2.Select "Bookmarks/Manage Bookmarks" menu item
3.Close browser window
4.Change the name for one of the bookmarks
5.Close and exit Mozilla
6.Re-launch Mozilla
7.Select "Bookmarks/Manage Bookmarks" menu item

Actual Results:  The name change is not remembered.

Expected Results:  The name change is remembered

The logic in navigator.js/Shutdown() for flushing the bookmarks RDF data source
should be moved to bookmarks.js/Shutdown().  It logically makes more sense
there.

Comment 1

17 years ago
Becki Sanford, Ben Goodger has supposedly fixed this in the nightly builds.
Could you please re-test? Thank you a lot!
(Reporter)

Comment 2

17 years ago
Retested with build ID 2001031408 (Linux PC) and it's still a problem.  ALL
steps must be performed in the given order to see the problem.
OK.  I see this with linux build 2001-03-14-05.  The name change is remembered
within the bookmark manager itself... just not written out to the RDF on disk.
The problem is as follows (clearer steps to reproduce)

1)  open bookmark manager
2)  close all mozilla windows but bookmark manager
3)  edit the name of a bookmark
4)  quit mozilla without opening any new navigator windows (hit Ctrl-q) in the
bookmark manager.
Blocks: 68550
Keywords: dataloss
Actually, I am guessing we need the logic in both places, since one can edit
bookmarks from a navigator window via the sidebar...

Attaching a simple patch that should fix this.
Created attachment 27725 [details] [diff] [review]
flush bookmarks to disk when bookmark manager is closed
I've tested this and it works, by the way.  Becki, thanks for including a
pointer to the problem in your report.  :)
Keywords: mozilla0.9, patch, review

Comment 7

17 years ago
blake, any chance you can give us a review here?  ben, can you sr this patch.  
just do 

gBookmarksShell.flushDataSource();

replace that code with this, and sr=ben. 

Comment 9

17 years ago
Do what Ben said and add an "// XXXBenGoodyer" comment and r=blake
/me smacks blake
asa, is this 0.9 material?  Or should we just hold off on it?

Comment 13

17 years ago
Checked in, marking fixed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 14

17 years ago
While dataloss like this is a real problem I don't think that this will be seen
often enoungh and I don't think the value of a bookmark name is high enough to
force this fix out to the branch.  Thanks for the trunk fix though.
mass-verifying claudius' Fixed bugs which haven't changed since 2001.12.31.

if you think this particular bug is not fixed, please make sure of the following
before reopening:

a. retest with a *recent* trunk build.
b. query bugzilla to see if there's an existing, open bug (new, reopened,
assigned) that covers your issue.
c. if this does need to be reopened, make sure there are specific steps to
reproduce (unless already provided and up-to-date).

thanks!

[set your search string in mail to "AmbassadorKoshNaranek" to filter out these
messages.]
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.