KB images don't load in Safari until you scroll the page

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
7 years ago
5 years ago

People

(Reporter: verdi, Assigned: tgavankar)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
In Safari on Mac (both the version shipping with OS 10.6 and 10.7), images in our KB articles don't show until you scroll the page. So on pages where there is an image near the top, for example, https://support.mozilla.org/en-US/kb/how-do-i-use-bookmarks , the page loads without images. Then when the user scrolls down the images appear.

The behavior should be like it is in Firefox and the images that should be in view, load with the page.
(Assignee)

Comment 1

7 years ago
I saw this happen the first time I tested it, but after that no matter what I do (including the "reset safari" option to clear _everything_ and a reinstall), I am unable to reproduce it. It lazyloads all the images appropriately...
Assignee: nobody → tgavankar
(Reporter)

Comment 2

7 years ago
It seems it doesn't happen every time but it does happen some of the time :|
http://people.mozilla.org/~mverdi/video/safari-images.webm
(Assignee)

Comment 3

7 years ago
X_X yum, heisenbugs.

I haven't been able to find any STR, but it does seem like the images always load when the user scrolls, so perhaps we should try by firing off a single scroll event on page load and see if that stops it from happening.
(Assignee)

Comment 4

7 years ago
Landed this on -dev: https://github.com/mozilla/kitsune/commit/ef85f43d

I didn't seem to be hitting the bug anymore, but seeing as it was a heisenbug with no STR, please REOPEN if you see it again. Marking as RESO FIXED for now.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2012-01-31
(Reporter)

Comment 5

7 years ago
First, let me say that I don't think this is a huge priority. 

I just loaded http://support-dev.allizom.org/en-US/kb/ask in safari and the two images in the article didn't load. Then I scrolled the page and they loaded.
*http://people.mozilla.org/~mverdi/screenshots/onload-20120123-143543.jpg
*http://people.mozilla.org/~mverdi/screenshots/after-scrolling-20120123-143627.jpg
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → NEW
Target Milestone: 2012-01-31 → ---
Tried with Safari, and all images loaded instantly. Please reopen if it persists.
Status: NEW → RESOLVED
Last Resolved: 7 years ago5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.