If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Tapping on the "Visit Site" button on an Untrusted Connection page doesn't seem to work

RESOLVED DUPLICATE of bug 659736

Status

()

Firefox for Android
General
P2
normal
RESOLVED DUPLICATE of bug 659736
6 years ago
a year ago

People

(Reporter: Martijn Wargers (dead), Assigned: bnicholson)

Tracking

12 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(blocking-fennec1.0 +, fennec11+)

Details

(URL)

(Reporter)

Description

6 years ago
the "Visit Site" and "Add permanent exception" buttons from the Untrusted Connection page don't seem to work.

Steps to reproduce:
- Go to https://people.mozilla.org , you should get the Untrusted Connection page
- Tap on "I Understand the Risks"
- Tap on the "Visit site" or the "Add permanent exception" button.

Expected result:
- the https://people.mozilla.org page gets shown

Actual result:
- The Untusted Connection page stays visible.
Assignee: nobody → mbrubeck
tracking-fennec: --- → 11+
Priority: -- → P2
Duplicate of this bug: 721647

Comment 2

6 years ago
This seems to work for me in the latest nightly.
Version: Trunk → Firefox 13

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Version: Firefox 13 → Firefox 12
(Reporter)

Comment 3

6 years ago
It seems to work better now, at least the first time, but I can still reproduce this with this new steps to reproduce:
- Go to https://people.mozilla.org , you should get the Untrusted Connection page
- Tap on "I Understand the Risks"
- Tap on the "Visit site", now you should get to the page that says "people.mozilla.com"
- Exit the browser, by going to the menu and tap on "Quit"
- Restart the browser
- Go to https://people.mozilla.org again, you should get the Untrusted Connection page again
- Tap on "I Understand the Risks"
- Tap on the "Visit site" button

Expected result:
- You should get to the page that says "people.mozilla.com"

Actual result:
- Stuck on the Untrusted Connection page again.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Martjin - Does "visit site" only create a temporary exception/ So if you quit fennec and restart, we forget the exception, right?
(Reporter)

Comment 5

6 years ago
Yes, that is what "visit site" does. For some reason, the second time visiting, the temporary exception is not set or something.
Re-assigning to Margaret since Matt is focused on the Add-on Manager
Assignee: mbrubeck → margaret.leibovic

Comment 7

6 years ago
I'm having trouble re-producing this. After quitting and restarting, going to https://people.mozilla.org just automatically goes to the site without showing me the Untrusted Connection page again.
(Reporter)

Comment 8

6 years ago
That shouldn't happen, after quitting, you shouldn't automatically go to the site, only if you've tapped on the "Add permanent exception" button.

I guess the bug has changed in something else.
Keywords: fennecnative-releaseblocker
blocking-fennec1.0: --- → +
(Assignee)

Updated

6 years ago
Assignee: margaret.leibovic → bnicholson
(Assignee)

Comment 9

6 years ago
It looks like this is a longstanding issue that is also present in Desktop Firefox. When the certificate is temporarily accepted, the page gets cached. When you quit and reopen the browser, it will go straight to the site as margaret mentioned in comment 7 (since it is simply showing the cached page). Reloading the page again shows the warning.

The "Visit site" button is broken for the same reason: we do an XHR request for the page in exceptions.js, and we expect to catch an error so we can get the SSL status. However, since we're getting the cached page, we'll simply get an HTTP 200, and the notifyCertProblem() callback won't get executed. This results in SSLStatus in _addOverride() being null, which breaks when we try to access SSLStatus.serverCert.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 660749
Duplicate of bug: 659736
You need to log in before you can comment on or make changes to this bug.