Crash with my own debug build shortly after start up

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
--
critical
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: Martijn Wargers (zombie), Unassigned)

Tracking

({crash})

Trunk
ARM
Android
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [native-crash])

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 590321 [details]
catlog of the crash that I'm getting

Dholbert mentioned bug 717441 to me, but that bug is fixed and I pulled a few hours ago and rebuilt.

I built on MacosX10.5 and tested the build on the LG Optimus Black. It crashes shortly after start up.

This is my .mozconfig file:
    # Add the correct paths here:
    ac_add_options --with-android-ndk="$HOME/android-ndk-r6b"
    ac_add_options --with-android-toolchain="$HOME/android-ndk-r6b/toolchains/arm-linux-androideabi-4.4.3/prebuilt/darwin-x86"
    ac_add_options --with-android-platform="$HOME/android-ndk-r6b/platforms/android-8/arch-arm"
    ac_add_options --with-android-tools="$HOME/android-sdk-mac_x86/tools"
    ac_add_options --with-android-sdk="$HOME/android-sdk-macosx/platforms/android-13"
    ac_add_options --with-android-version=8
     
    # android options
    ac_add_options --enable-debug
    ac_add_options --disable-optimize
    #ac_add_options --with-ccache
    ac_add_options --disable-crashreporter
     
    mk_add_options MOZ_OBJDIR=./objdir-droid
    mk_add_options MOZ_MAKE_FLAGS="-j16 -s"
     
    # Android options
    ac_add_options --enable-application=mobile/android
    ac_add_options --target=arm-linux-androideabi
     
    mk_add_options AUTOCONF=/usr/local/Cellar/autoconf213/2.13/bin/autoconf213
(Reporter)

Updated

7 years ago
Summary: Crash with my own build shortly after start up → Crash with my own debug build shortly after start up

Updated

7 years ago
Severity: normal → critical
Keywords: crash
Whiteboard: [native-crash]

Comment 1

7 years ago
any idea what checkin broke this?  It is very important that debug builds work.
Keywords: regressionwindow-wanted

Comment 2

7 years ago
(In reply to Doug Turner (:dougt) from comment #1)
> any idea what checkin broke this?  It is very important that debug builds
> work.

Martijn, can you confirm if another device crashes in the same way?  (we already know your LG Optimus Black has a history of badness with Fennec: https://bugzilla.mozilla.org/show_bug.cgi?id=670525#c6)

Also, please help locate a regression range.  Thanks.
(Reporter)

Comment 3

7 years ago
Created attachment 590918 [details]
Catlog of debug build of today

Sorry, haven't had time to find a regression range for this, yet.

I tried at least if a debug build from today would fix the crash, but in today's debug build it even seems to crash quicker. The UI doesn't even come up now (or very briefly).
This is a catlog of that crash.

This debug build at least, is also crashing on the EeeTransformer TF101 and the Motorola Droid 1.
Today's debug builds were crashing because of a recent linker change. See http://groups.google.com/group/mozilla.dev.platforms.mobile/browse_thread/thread/af38a029b1ed62b4# for workarounds.
Glandium, did you file a bug for this issue? if so, please mark the dupe
Assignee: nobody → mh+mozilla
While the second crash in this bug is related to the linker change, the first one is not, so it can't really be duped. FWIW, I filed bug 720621.
Assignee: mh+mozilla → nobody
(Reporter)

Updated

7 years ago
Depends on: 720621
(Reporter)

Comment 7

7 years ago
Ok, today, I built again, installed it on my LG Optimus Black phone and it doesn't crash on startup (after adding the "export MOZ_OLD_LINKER=1" workaround mentioned in http://groups.google.com/group/mozilla.dev.platforms.mobile/browse_thread/thread/af38a029b1ed62b4 ).
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.