IonMonkey: Sudden bailout in crypto-md5:201.

RESOLVED DUPLICATE of bug 590044

Status

()

RESOLVED DUPLICATE of bug 590044
7 years ago
7 years ago

People

(Reporter: sstangl, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
We generate the following MIR for crypto-md5:201, the first function called:

[11] Unbox parameter3 [String]
[39] Phi unbox11 unbox 36 [String]
[202] Box phi-39 [Value]
[204] Unbox box-202 [Object]

Unsurprisingly this is not performant. Bailing out causes us to take up 6ms (~30% of total execution time) handling this function in the interpreter.
(Reporter)

Comment 1

7 years ago
Fixed by patch in bug 590044 -- CallGetProperty needs the String prototype as input instead of the String itself.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 590044
You need to log in before you can comment on or make changes to this bug.