Intermittent Android crash in /tests/dom/tests/mochitest/dom-level0/test_innerWidthHeight_script.html

RESOLVED WORKSFORME

Status

()

defect
P3
critical
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: mbrubeck, Unassigned)

Tracking

({intermittent-failure})

12 Branch
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(fennec+)

Details

(Whiteboard: [test which aborts the suite][tegra][android_tier_1])

Possibly related to bug 720064, but hard to tell.

https://tbpl.mozilla.org/php/getParsedLog.php?id=8706589&tree=Mozilla-Inbound
Android Tegra 250 mozilla-inbound opt test mochitest-1 on 2012-01-20 14:12:29 PST for push cf45def338fa

20497 INFO TEST-START | /tests/dom/tests/mochitest/dom-level0/test_innerWidthHeight_script.html
20498 INFO TEST-PASS | /tests/dom/tests/mochitest/dom-level0/test_innerWidthHeight_script.html | innerWidth is css viewport width - 320 should equal 320
20499 INFO TEST-PASS | /tests/dom/tests/mochitest/dom-level0/test_innerWidthHeight_script.html | innerHeight is css viewport height - 320 should equal 320
20500 INFO TEST-PASS | /tests/dom/tests/mochitest/dom-level0/test_innerWidthHeight_script.html | innerWidth returns value that was set - 300 should equal 300
20501 INFO TEST-PASS | /tests/dom/tests/mochitest/dom-level0/test_innerWidthHeight_script.html | innerHeight returns value that was set - 300 should equal 300
INFO | automation.py | Application ran for: 0:03:39.180209
INFO | automation.py | Reading PID log: /tmp/tmpnexFNrpidlog
getting files in '/mnt/sdcard/tests/profile/minidumps/'
PROCESS-CRASH | automation.py | application crashed (minidump found)
Crash dump filename: /tmp/tmpXKTjio/04f32957-b783-646f-2049fdef-317f37f8.dmp
MINIDUMP_STACKWALK not set, can't process dump.
WARNING | automationutils.processLeakLog() | refcount logging is off, so leaks can't be detected!

INFO | runtests.py | Running tests: end.
removing file: /mnt/sdcard/tests/logs/mochitest.log
program finished with exit code 0
elapsedTime=244.661217
tracking-fennec: --- → +
Priority: -- → P3
Exception from the full log is:

01-20 14:19:54.108 E/GeckoApp( 1629): top level exception
01-20 14:19:54.108 E/GeckoApp( 1629): java.lang.NullPointerException
01-20 14:19:54.108 E/GeckoApp( 1629): 	at org.mozilla.gecko.BrowserToolbar.setFavicon(BrowserToolbar.java:280)
01-20 14:19:54.108 E/GeckoApp( 1629): 	at org.mozilla.gecko.GeckoApp$5.run(GeckoApp.java:729)
01-20 14:19:54.108 E/GeckoApp( 1629): 	at android.os.Handler.handleCallback(Handler.java:587)
01-20 14:19:54.108 E/GeckoApp( 1629): 	at android.os.Handler.dispatchMessage(Handler.java:92)
01-20 14:19:54.108 E/GeckoApp( 1629): 	at android.os.Looper.loop(Looper.java:123)
01-20 14:19:54.108 E/GeckoApp( 1629): 	at org.mozilla.gecko.GeckoApp$31.run(GeckoApp.java:1556)
01-20 14:19:54.108 E/GeckoApp( 1629): 	at android.os.Handler.handleCallback(Handler.java:587)
01-20 14:19:54.108 E/GeckoApp( 1629): 	at android.os.Handler.dispatchMessage(Handler.java:92)
01-20 14:19:54.108 E/GeckoApp( 1629): 	at android.os.Looper.loop(Looper.java:123)
01-20 14:19:54.108 E/GeckoApp( 1629): 	at android.app.ActivityThread.main(ActivityThread.java:4627)
01-20 14:19:54.108 E/GeckoApp( 1629): 	at java.lang.reflect.Method.invokeNative(Native Method)
01-20 14:19:54.108 E/GeckoApp( 1629): 	at java.lang.reflect.Method.invoke(Method.java:521)
01-20 14:19:54.108 E/GeckoApp( 1629): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:868)
01-20 14:19:54.108 E/GeckoApp( 1629): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:626)
01-20 14:19:54.108 E/GeckoApp( 1629): 	at dalvik.system.NativeStart.main(Native Method)

Same deal as bug 720064 - caused by Tabs.getInstance().getSelectedTab() returning null, and may be fixed already since that code has changed considerably.
Mass marking whiteboard:[orange] bugs WFM (to clean up TBPL bug suggestions) that:
* Haven't changed in > 6months
* Whose whiteboard contains none of the strings: {disabled,marked,random,fuzzy,todo,fails,failing,annotated,leave open,time-bomb}
* Passed a (quick) manual inspection of bug summary/whiteboard to ensure they weren't a false positive.

I've also gone through and searched for cases where the whiteboard wasn't labelled correctly after test disabling, by using attachment description & basic comment searches. However if the test for which this bug was about has in fact been disabled/annotated/..., please accept my apologies & reopen/mark the whiteboard appropriately so this doesn't get re-closed in the future (and please ping me via IRC or email so I can try to tweak the saved searches to avoid more edge cases).

Sorry for the spam! Filter on: #FFA500
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Whiteboard: [orange][test which aborts the suite][tegra][android_tier_1] → [test which aborts the suite][tegra][android_tier_1]
You need to log in before you can comment on or make changes to this bug.