The default bug view has changed. See this FAQ.

"nsFilePicker.cpp(992) : error C2027: use of undefined type 'IFileDialog'" when using"--with-windows-version=502"

VERIFIED FIXED in Firefox 11

Status

()

Core
Widget: Win32
--
blocker
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: sgautherie, Assigned: sgautherie)

Tracking

({regression})

Trunk
mozilla12
x86
Windows Server 2003
regression
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox11 verified)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

5 years ago
https://tbpl.mozilla.org/?tree=Try&rev=bbd3d57cd482
https://tbpl.mozilla.org/php/getParsedLog.php?id=8692443&tree=Try
WINNT 5.2 try build on 2012-01-20 02:45:01 PST for push bbd3d57cd482
https://tbpl.mozilla.org/php/getParsedLog.php?id=8692502&tree=Try
WINNT 5.2 try leak test build on 2012-01-20 02:45:01 PST for push bbd3d57cd482
{
.../widget/src/windows/nsFilePicker.cpp(992) : error C2027: use of undefined type 'IFileDialog'
...
}
Flags: in-testsuite-
(Assignee)

Comment 1

5 years ago
http://msdn.microsoft.com/en-us/library/windows/desktop/bb775966(v=vs.85).aspx
{
Minimum supported client
Windows Vista
}
Summary: "gfxWindowsPlatform.cpp(485) : error C2065: 'gfxDWriteFont' : undeclared identifier" when using "--with-windows-version=502" → "nsFilePicker.cpp(992) : error C2027: use of undefined type 'IFileDialog'" when using"--with-windows-version=502"
Eh, makes the case for bug 699385 even stronger.
(Assignee)

Comment 3

5 years ago
Created attachment 590641 [details] [diff] [review]
(Av1) Fix windows/nsFilePicker to actually be buildable using "--with-windows-version=502"

(In reply to Siddharth Agarwal [:sid0] from comment #2)
> Eh, makes the case for bug 699385 even stronger.

Yeah. Nonetheless, for now, it just misses 2 SDK checks (to complete the existing ones).

Succeeded as https://tbpl.mozilla.org/?tree=Try&rev=ce1c31e55fe1 (12a1)
Attachment #590641 - Flags: review?(jmathies)

Comment 4

5 years ago
Created attachment 590709 [details] [diff] [review]
(Av1a) Fix windows/nsFilePicker to actually be buildable using "--with-windows-version=502"
[Checked in: Comment 7]

Can we take a slightly different route here - this strips the new methods out based on the sdk version. (Since we were already completely ifdef'ing out ShowFolderPicker, ComDlgFilterSpec, and IFileDialogEvents.) I don't have the sdk to test build this unfortunately.
(Assignee)

Comment 5

5 years ago
Comment on attachment 590709 [details] [diff] [review]
(Av1a) Fix windows/nsFilePicker to actually be buildable using "--with-windows-version=502"
[Checked in: Comment 7]

(In reply to Jim Mathies [:jimm] from comment #4)

> Can we take a slightly different route here - this strips the new methods
> out based on the sdk version. (Since we were already completely ifdef'ing
> out ShowFolderPicker, ComDlgFilterSpec, and IFileDialogEvents.)

I fully concur: I just missed to fully complete that ;-/

> I don't have the sdk to test build this unfortunately.

I confirm at 100% by code inspection.
Submitted as https://tbpl.mozilla.org/?tree=Try&rev=29f447226b75 , just in case.
Attachment #590709 - Attachment description: patch → (Av1a) Fix windows/nsFilePicker to actually be buildable using "--with-windows-version=502"
Attachment #590709 - Attachment filename: tmp.txt → 720071-Av1a-12a1_nsFilePicker.diff
Attachment #590709 - Flags: review?(jmathies)
(Assignee)

Updated

5 years ago
Attachment #590641 - Attachment is obsolete: true
Attachment #590641 - Flags: review?(jmathies)

Comment 6

5 years ago
Comment on attachment 590709 [details] [diff] [review]
(Av1a) Fix windows/nsFilePicker to actually be buildable using "--with-windows-version=502"
[Checked in: Comment 7]

try builds completed successfully.
Attachment #590709 - Flags: review?(jmathies) → review+
(Assignee)

Comment 7

5 years ago
Comment on attachment 590709 [details] [diff] [review]
(Av1a) Fix windows/nsFilePicker to actually be buildable using "--with-windows-version=502"
[Checked in: Comment 7]

https://hg.mozilla.org/mozilla-central/rev/3be494e4cc8f
Attachment #590709 - Attachment description: (Av1a) Fix windows/nsFilePicker to actually be buildable using "--with-windows-version=502" → (Av1a) Fix windows/nsFilePicker to actually be buildable using "--with-windows-version=502" [Checked in: Comment 7]
(Assignee)

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
tracking-firefox12: ? → ---
Resolution: --- → FIXED
Target Milestone: --- → mozilla12
(Assignee)

Comment 8

5 years ago
Created attachment 591002 [details] [diff] [review]
(Bv1-11a1) Fix windows/nsFilePicker to actually be buildable using "--with-windows-version=502" [Checkin: Comment 14]

Av1a, with context fixed to apply on 11a1 aurora default.

[Approval Request Comment]
Regression caused by (bug #): bug 661991.
User impact if declined: none, but impossible to build (on Windows 2000) with P.SDK 2003R2.
Testing completed (on m-c, etc.): multiple Try builds and comment 7.
Risk to taking this patch (and alternatives if risky): no risk, trivial addition of missing build time conditions.
Attachment #591002 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 9

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=8780739&tree=Firefox
WINNT 5.2 mozilla-central build on 2012-01-23 22:08:54 PST for push 3be494e4cc8f
still succeeds.

V.Fixed
Status: RESOLVED → VERIFIED
Comment on attachment 591002 [details] [diff] [review]
(Bv1-11a1) Fix windows/nsFilePicker to actually be buildable using "--with-windows-version=502" [Checkin: Comment 14]

[Triage Comment]
In support of building on Windows 2000 - approved for Aurora.
Attachment #591002 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
Whiteboard: [c-n: Bv1-11a1 to m-a]
(Assignee)

Updated

5 years ago
Depends on: 699385
No longer depends on: 629827
Missed aurora; removing checkin-needed to tidy checkin-needed saved search; presume you need to re-request for beta (if still wanted) anyway.
Keywords: checkin-needed
Whiteboard: [c-n: Bv1-11a1 to m-a]
(Assignee)

Comment 12

5 years ago
Comment on attachment 591002 [details] [diff] [review]
(Bv1-11a1) Fix windows/nsFilePicker to actually be buildable using "--with-windows-version=502" [Checkin: Comment 14]

[Approval Request Comment]
Per comment 11.
Attachment #591002 - Flags: approval-mozilla-beta?
Comment on attachment 591002 [details] [diff] [review]
(Bv1-11a1) Fix windows/nsFilePicker to actually be buildable using "--with-windows-version=502" [Checkin: Comment 14]

[Triage Comment]
This patch has now baked on m-c (and Aurora 12 since we pushed it out Friday). Approving for Beta 11.
Attachment #591002 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
Whiteboard: [c-n: Bv1-11a1 to m-b]
Comment on attachment 591002 [details] [diff] [review]
(Bv1-11a1) Fix windows/nsFilePicker to actually be buildable using "--with-windows-version=502" [Checkin: Comment 14]

http://hg.mozilla.org/releases/mozilla-beta/rev/7d66ee5164c0
Attachment #591002 - Attachment description: (Bv1-11a1) Fix windows/nsFilePicker to actually be buildable using "--with-windows-version=502" → (Bv1-11a1) Fix windows/nsFilePicker to actually be buildable using "--with-windows-version=502" [Checkin: Comment 14]
status-firefox11: affected → fixed
Keywords: checkin-needed
Whiteboard: [c-n: Bv1-11a1 to m-b]
(Assignee)

Comment 15

5 years ago
https://tbpl.mozilla.org/?tree=Mozilla-Beta&rev=afcb5dfe30eb
is still green.

firefox11: verified.
status-firefox11: fixed → verified
You need to log in before you can comment on or make changes to this bug.