Closed Bug 720101 Opened 10 years ago Closed 10 years ago

Chrome file doesn't exist: .../chrome/toolkit/content/global/autocomplete.css

Categories

(Toolkit :: Themes, defect)

All
macOS
defect
Not set
trivial

Tracking

()

RESOLVED FIXED
mozilla13

People

(Reporter: MattN, Assigned: MattN)

References

()

Details

Attachments

(1 file)

This warning appears on every startup for me:
Chrome file doesn't exist: .../chrome/toolkit/content/global/autocomplete.css

It's caused by a CSS import in pinstripe for chrome://global/content/autocomplete.css which doesn't exist in Firefox builds.  It seems like this import can simply be deleted for Firefox but I'm not sure if it's used to provide some additional styles in other applications.

This warning has been around for a while but I can't find any bug on file about it.
Attachment #590447 - Flags: feedback?(dao)
Attachment #590447 - Flags: feedback?(dao) → review+
Blake, from what I can tell, Thunderbird is using this import since chrome://global/content/autocomplete.css is defined there.  Can this line be moved to Thunderbird's theme so that other applications who don't use this can avoid the warning?
Assignee: nobody → mnoorenberghe+bmo
Status: NEW → ASSIGNED
I have no problem with that, but you should also check with one of the SeaMonkey people to see if that's okay by them too…

Thanks,
Blake.
Duplicate of this bug: 720649
(In reply to Blake Winton (:bwinton - Thunderbird UX) from comment #2)
> I have no problem with that, but you should also check with one of the
> SeaMonkey people to see if that's okay by them too…
> 
> Thanks,
> Blake.

I don't see any problem with removing the import rule in pinstripe's autocomplete.css. xpfe's autocomplete.xml is already refering to its own autocomplete.css. The reason the pinstripe import exists, is probably just because someone have forgotten to remove it. Iotw, anyone using /xpfe/components/autocomplete/resources/content/autocomplete.xml should automatically get xpfe/components/autocomplete/resources/content/autocomplete.css (some rules here seems to also exist in toolkit's xul.css).
Blocks: 722077
https://hg.mozilla.org/mozilla-central/rev/a5bd3f716d86
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.