Corruption on some parts of the page (related to text input caret?)

RESOLVED DUPLICATE of bug 721383

Status

()

Firefox for Android
General
P2
normal
RESOLVED DUPLICATE of bug 721383
6 years ago
6 years ago

People

(Reporter: Martijn Wargers (dead), Assigned: dougt)

Tracking

({regression, testcase})

Trunk
ARM
Android
regression, testcase
Points:
---

Firefox Tracking Flags

(blocking-fennec1.0 +, fennec11+)

Details

Attachments

(4 attachments)

(Reporter)

Description

6 years ago
Created attachment 590468 [details]
testcase

Tested on the LG Optimus Black, Android 2.2.2.

Steps to reproduce:
- Go to testcase
- Tap randomly (somewher in the middle) on text inputs, until you see parts of the page get corrupted.

There is no good steps to reproduce, because it happens itermittenly.
Usually, it happens after tapping 5 times on one of the inputs in the testcase.

I don't even know if this is related to text inputs and focussing them. I think I've seen this happening sometimes on other pages as well, but less frequent.

I can't really remember seeing this happening in older builds.
(Reporter)

Comment 1

6 years ago
Created attachment 590469 [details]
Screenshot of bug
(Reporter)

Comment 2

6 years ago
Created attachment 590471 [details]
corruption in about:config
Crashed with 2 different signatures by changing orientations panning in 2 tabs, and then clicking in the field on a nexus s but it's way too hard to reproduce.  I think it may have to do with some sort of race condition.  Possibly related to bug 720160?
(Reporter)

Updated

6 years ago
Depends on: 720160
Assignee: nobody → pwalton
tracking-fennec: --- → 11+
Priority: -- → P2
(Reporter)

Comment 4

6 years ago
It's not necessarily limited to text inputs only, I've seen it on various pages.
(Reporter)

Comment 5

6 years ago
Created attachment 591487 [details]
Corruption in about:firefox

Now I got it just by going to about:firefox and tapping on the Update button.
(Assignee)

Comment 6

6 years ago
wierd?  possible driver issue?  I'd like to get ahold of this device.
Assignee: pwalton → doug.turner
(Reporter)

Comment 7

6 years ago
I got this very quickly while typing with the testcase from bug 721393: https://bugzilla.mozilla.org/attachment.cgi?id=591801
(Reporter)

Updated

6 years ago
No longer depends on: 720160
(Reporter)

Comment 8

6 years ago
I suspect very much that this is related to bug 721383. I see that happening with the testcase of that bug too, and here I'm seeing sometimes hangs and crashes too. This also has started around the same time as bug 721383 started.

So I guess this is a regression from bug 716415 also.
Depends on: 721383
Keywords: regression
Keywords: fennecnative-releaseblocker
blocking-fennec1.0: --- → +
Status: NEW → ASSIGNED
(Assignee)

Updated

6 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 721383
You need to log in before you can comment on or make changes to this bug.