Close GUI, process keeps running preventing GUI from being restarted

RESOLVED INCOMPLETE

Status

Thunderbird
General
--
critical
RESOLVED INCOMPLETE
6 years ago
6 years ago

People

(Reporter: Doug Hockin, Unassigned)

Tracking

({hang})

9 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111220165912

Steps to reproduce:

TB was running. I had just moved 2000+ emails from one folder to another. I closed TB. 


Actual results:

The a little later tried to restart it, but the the message saying it was already running. I watched the Task Manager and eventually it exited and I could restart the GUI.


Expected results:

The process shouldn't keep running when the GUI is gone. To ordinary folks who know nothing about "processes" the error message is very confusing because it's obviously "not running" anymore.

Was it perhaps re-indexing all those emails?

Comment 1

6 years ago
(In reply to Doug Hockin from comment #0)
See bug 698973.
(Reporter)

Comment 2

6 years ago
Symptoms of bug 698973 don't match mine. TB is still running, it shows in the task manager. The error message is not bogus, the question is why does TB keep running after I exit the GUI?
(Reporter)

Comment 3

6 years ago
And my profile is not missing and is not corrupt. TB was truly running, doing something that prevented it from exiting after I closed the GUI. After some time it finished doing whatever it was doing and exited of it's own accord.
(In reply to Doug Hockin from comment #3)
> And my profile is not missing and is not corrupt. TB was truly running,
> doing something that prevented it from exiting after I closed the GUI. After
> some time it finished doing whatever it was doing and exited of it's own
> accord.

Doug if you can reproduce you might be able to diagnose these folowing the instructions at https://wiki.mozilla.org/Thunderbird:Testing:Shutdown_Hang

Comment 5

6 years ago
Please update the bug when you have more info.
Severity: normal → critical
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Keywords: hang
Resolution: --- → INCOMPLETE
(Reporter)

Comment 6

6 years ago
I haven't seen it happen for a long time, and since I started using my iPod Touch for my email I just don't use TB much anymore.
You need to log in before you can comment on or make changes to this bug.