document.close nor window.close will not close a tab

RESOLVED INVALID

Status

()

Firefox for Android
General
RESOLVED INVALID
7 years ago
5 years ago

People

(Reporter: nhirata, Unassigned)

Tracking

12 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 590633 [details]
close page

1. download the close.html file
2. do an adb push close.html /sdcard/download
3. do an adb shell am start -a android.intent.action.VIEW -n org.mozilla.fennec/.App -d file://mnt/sdcard/download/close.html

Expected: the file will open in fennec in a new tab and the close itself
Actual: the file will open in fennec in a new tab and remain open

Note:
This is causing an issue with the semi automated perf, because the tabs are all restoring causing addition time.  I need a way to close the tabs.
Is this a recent regression? I thought we had this working.

Comment 2

7 years ago
(In reply to Mark Finkle (:mfinkle) from comment #1)
> Is this a recent regression? I thought we had this working.

My patch was backed out, so I wouldn't have caused a regression.

window.close() is not expected to work unless the window was opened with window.open() [1], so this bug is actually invalid. I wrote a test case for this a few days ago [2], and I just verified it still works.

[1] https://developer.mozilla.org/en/DOM/window.close#Description
[2] http://people.mozilla.com/~mleibovic/test/window-open.html
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(Assignee)

Updated

5 years ago
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.