Only the last letter typed is displayed when HKB is used

VERIFIED FIXED in Firefox 11

Status

()

Firefox for Android
General
P2
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Carla Nadastean, Assigned: alexp)

Tracking

({inputmethod})

Trunk
Firefox 12
ARM
Android
inputmethod
Points:
---

Firefox Tracking Flags

(firefox11 fixed, blocking-fennec1.0 beta+, fennec11+)

Details

(Whiteboard: [HKB])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Build: Fennec/12.0a1 (2012-01-22)
HTC Desire Z (Android 2.3)

Steps to reproduce:
1. Open Fennec app in landscape mode.
2. Navigate to http://www.amazon.com
3. Select the search field.
4. Type something using HKB.

Expected Result:
The text typed should be properly displayed in the search field.

Actual Result: 
Only the last typed letter is displayed.
(Reporter)

Updated

5 years ago
status-firefox11: --- → unaffected
status-firefox12: --- → affected
Carla, what software keyboard do you have enabled? (the software keyboard changes how the hardware keyboard behaves)
Assignee: nobody → alexp
tracking-fennec: --- → 11+
Priority: -- → P2
(Reporter)

Comment 2

5 years ago
The Touch Input software keyboard is enabled on the device.
I'm seeing this also. Happens in portrait or landscape, on (so far) any web content input field. I'm testing on my trusty ole Motorola Droid Pro running 2.2.1 with the default IME.
A nightly that I have from a while ago (rev c713003d3226) doesn't have this problem, so it's a regression in the last few weeks at most. I can bisect a bit more using tinderbox builds.
Regression range: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=49936b49aff3&tochange=099ec081e8aa

(49936b49aff3 doesn't demonstrate this problem, but 099ec081e8aa does). Also note that if I remove focus from the input field after typing one character, and then put focus back into the input field and type, the first character remains as is, and the second character (i.e. the new last character) is the one that keeps getting replaced by the newly typed input.
(Assignee)

Updated

5 years ago
Duplicate of this bug: 721250
(Assignee)

Updated

5 years ago
Keywords: inputmethod
Summary: Only the last letter typed is displayed in landscape mode when HKB is used → Only the last letter typed is displayed when HKB is used
Whiteboard: [HKB]
(Assignee)

Updated

5 years ago
Duplicate of this bug: 721231
(Assignee)

Comment 8

5 years ago
Created attachment 591666 [details] [diff] [review]
Fix

Reset the composition when a changed text range is different from the last composing range.
Attachment #591666 - Flags: review?(blassey.bugs)
Attachment #591666 - Flags: review?(blassey.bugs) → review+
(Assignee)

Comment 9

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/59f3e45dc542
https://hg.mozilla.org/mozilla-central/rev/59f3e45dc542
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Duplicate of this bug: 721613
why is aurora not effected by this? Is this a regression from a patch that hasn't made it to aurora yet?
(Assignee)

Comment 13

5 years ago
Looks like the bug 711648, which was the cause of this issue, hasn't made it yet.
Alex, mark the dependency and request aurora approval
(Assignee)

Comment 15

5 years ago
Comment on attachment 591666 [details] [diff] [review]
Fix

[Approval Request Comment]
Regression caused by (bug #): 711648
User impact if declined: Impossible to type with HKB.
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): Low, mobile only.
Attachment #591666 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

5 years ago
Depends on: 711648
Comment on attachment 591666 [details] [diff] [review]
Fix

[Triage Comment]
Mobile only - approved for Beta 11.
Attachment #591666 - Flags: approval-mozilla-aurora? → approval-mozilla-beta+

Updated

5 years ago
status-firefox11: unaffected → affected
status-firefox12: affected → ---
Keywords: fennecnative-betablocker
https://hg.mozilla.org/releases/mozilla-beta/rev/5eb947a9a03d
status-firefox11: affected → fixed

Comment 18

5 years ago
Verified on: 
2012-02-08 Firefox/11.0 
2012-02-08 Firefox/12.0a1 Fennec/12.0a
2012-02-08 Firefox/13.0a1 Fennec/13.0a

Bug no longer reproducible.
Status: RESOLVED → VERIFIED
blocking-fennec1.0: --- → beta+
Duplicate of this bug: 723664
You need to log in before you can comment on or make changes to this bug.