Closed Bug 720361 Opened 8 years ago Closed 8 years ago

Speed of opening the tabs menu (org.mozilla.gecko.TabsTray) has regressed in performance recently

Categories

(Firefox for Android :: General, defect, major)

ARM
Android
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 721216
Tracking Status
firefox12 --- affected

People

(Reporter: aaronmt, Assigned: blassey)

References

Details

(Keywords: perf, regression, reproducible, Whiteboard: [QA^], tabs-ux)

Attachments

(1 obsolete file)

Nexus S (Android 4.0.3) w/ 2 tabs (amazon.com/microsoft.com)

* I/ActivityManager(  154): Displayed org.mozilla.fennec/org.mozilla.gecko.TabsTray: +2s372ms
* I/ActivityManager(  154): Displayed org.mozilla.fennec/org.mozilla.gecko.TabsTray: +2s346ms
* I/ActivityManager(  154): Displayed org.mozilla.fennec/org.mozilla.gecko.TabsTray: +2s356ms

Samsung Galaxy SII (Android 2.3.4) w/ 2 tabs (ebay.com/nba.com)

* I/ActivityManager(  212): Displayed org.mozilla.fennec/org.mozilla.gecko.TabsTray: +2s173ms
* I/ActivityManager(  212): Displayed org.mozilla.fennec/org.mozilla.gecko.TabsTray: +2s181ms
* I/ActivityManager(  212): Displayed org.mozilla.fennec/org.mozilla.gecko.TabsTray: +2s194ms

Motorola Droid Pro (Android 2.3) w/ 2 tabs (cnn.com, thestar.com)

* I/ActivityManager(  154): Displayed org.mozilla.fennec/org.mozilla.gecko.TabsTray: +3s452ms
* I/ActivityManager(  154): Displayed org.mozilla.fennec/org.mozilla.gecko.TabsTray: +3s243ms
* I/ActivityManager(  154): Displayed org.mozilla.fennec/org.mozilla.gecko.TabsTray: +3s587ms

--
Samsung Nexus S (Android 4.0.3), Samsung Galaxy SII (Android 2.3.4), Motorola Droid Pro (Android 2.3)
Mozilla/5.0 (Android; Linux armv7l; rv:12.0a1) Gecko/20120123 Firefox/12.0a1 Fennec/12.0a1
Difference in comparison:

Nexus S (Android 4.0.3) w/ 2 tabs (amazon.com/microsoft.com)

* I/ActivityManager(  154): Displayed org.mozilla.fennec/org.mozilla.gecko.TabsTray: +287ms
* I/ActivityManager(  154): Displayed org.mozilla.fennec/org.mozilla.gecko.TabsTray: +234ms
* I/ActivityManager(  154): Displayed org.mozilla.fennec/org.mozilla.gecko.TabsTray: +263ms

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=58e933465c36&tochange=5c2bc94d359c
Summary: Speed of opening the tabs menu (org.mozilla.gecko.TabsTray) has regressed in performance → Speed of opening the tabs menu (org.mozilla.gecko.TabsTray) has regressed in performance recently
Regression from bug 719233

10:59 AaronMT: Enabled direct-texture: I/ActivityManager( 2715): Displayed org.mozilla.fennec/org.mozilla.gecko.TabsTray: +143ms
11:00 snorp: oh I see, so gralloc path is better because it's async presumably
Blocks: 719233
Duplicate of this bug: 719908
direct-texture.force.enabled; true

--

Nexus S (Android 4.0.3) w/ 2 tabs (amazon.com/microsoft.com)

* I/ActivityManager(  150): Displayed org.mozilla.fennec/org.mozilla.gecko.TabsTray: +211ms
* I/ActivityManager(  150): Displayed org.mozilla.fennec/org.mozilla.gecko.TabsTray: +225ms
* I/ActivityManager(  150): Displayed org.mozilla.fennec/org.mozilla.gecko.TabsTray: +235ms

Samsung Galaxy SII (Android 2.3.4) w/ 2 tabs (ebay.com/nba.com)

* I/ActivityManager( 2715): Displayed org.mozilla.fennec/org.mozilla.gecko.TabsTray: +354ms
* I/ActivityManager( 2715): Displayed org.mozilla.fennec/org.mozilla.gecko.TabsTray: +351ms
* I/ActivityManager( 2715): Displayed org.mozilla.fennec/org.mozilla.gecko.TabsTray: +327ms
Thinking out loud: Aurora only recently got gralloc support. Has Aurora always been slow to open the tab menu?
Galaxy Nexus (Android 4.0.3) w/ 2 tabs (amazon.com/neowin.net)

direct-texture.force.enabled; false

--

* I/ActivityManager(  196): Displayed org.mozilla.fennec/org.mozilla.gecko.TabsTray: +408ms
* I/ActivityManager(  196): Displayed org.mozilla.fennec/org.mozilla.gecko.TabsTray: +364ms
* I/ActivityManager(  196): Displayed org.mozilla.fennec/org.mozilla.gecko.TabsTray: +392ms

--

direct-texture.force.enabled; true

* I/ActivityManager(  196): Displayed org.mozilla.fennec/org.mozilla.gecko.TabsTray: +313ms
* I/ActivityManager(  196): Displayed org.mozilla.fennec/org.mozilla.gecko.TabsTray: +310ms
* I/ActivityManager(  196): Displayed org.mozilla.fennec/org.mozilla.gecko.TabsTray: +324ms


Fast device, but slight improvement
Whiteboard: [QA^]
Whiteboard: [QA^] → [QA^], tabs-ux
Attached patch patch to make screenshots (obsolete) — Splinter Review
Assignee: nobody → blassey.bugs
Attachment #591514 - Flags: review?(mark.finkle)
Comment on attachment 591514 [details] [diff] [review]
patch to make screenshots

this patch actually does nothing to address this bug. Opened bug 721208 and put it there
Attachment #591514 - Attachment is obsolete: true
Attachment #591514 - Flags: review?(mark.finkle)
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 721216
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.