Closed Bug 720507 Opened 9 years ago Closed 9 years ago

Render glitch in MathML

Categories

(Core :: MathML, defect)

9 Branch
x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 518172

People

(Reporter: cmt.miniBill, Unassigned)

Details

Attachments

(1 file)

Attached image Screenshot
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:9.0) Gecko/20100101 Firefox/9.0
Build ID: 20120114215613

Steps to reproduce:

Go here: http://mathscribe.com/author/jqmath.html
Look at the attached picture.
Drag pointer from green to blue dot.


Actual results:

There is a glitch in the rendering


Expected results:

No glitch
More data:
The bug appears iff the two integrals have different sizes

Asked a few people:
reproduced on
9.0 on gentoo [me]
9.0.1 on arch

not reproduced on
9.0.1 on ubuntu
9.0.1 on windows 7
Component: Untriaged → MathML
Product: Firefox → Core
QA Contact: untriaged → mathml
I think you don't have STIX fonts installed and thus Firefox uses a scale transform to draw integrals. When I implemented this method, I found painting issues, but I can not currently reproduce the bug.
Yes, I don't have stix-fonts installed.
Anything I can do to help you reproduce or at least triage the bug?
I know Gentoo builds with --enable-system-cairo.  Does arch also do that?  Check about:buildconfig.  This is likely a duplicate of bug 518172.
(In reply to cmt.miniBill from comment #3)
> Yes, I don't have stix-fonts installed.
> Anything I can do to help you reproduce or at least triage the bug?

What does about:buildconfig give for you?
Whiteboard: [closeme 2012-04-27 DUPLICATE 518172]
about:buildconfig
Build platform
target
x86_64-pc-linux-gnu
Build tools
Compiler 	Version 	Compiler flags
x86_64-pc-linux-gnu-gcc 	gcc version 4.5.3 (Gentoo 4.5.3-r1 p1.0, pie-0.4.5) 	-Wall -W -Wno-unused -Wpointer-arith -Wdeclaration-after-statement -Wcast-align -W -march=native -pipe -mno-avx -fno-strict-aliasing -pthread -ffunction-sections -fdata-sections -pipe -DNDEBUG -DTRIMMED -g -Os -freorder-blocks -finline-limit=50 -fomit-frame-pointer
x86_64-pc-linux-gnu-g++ 	gcc version 4.5.3 (Gentoo 4.5.3-r1 p1.0, pie-0.4.5) 	-fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -march=native -pipe -mno-avx -fno-strict-aliasing -std=gnu++0x -pthread -ffunction-sections -fdata-sections -pipe -DNDEBUG -DTRIMMED -g -Os -freorder-blocks -finline-limit=50 -fomit-frame-pointer
Configure arguments

--enable-application=browser --enable-optimize --with-system-jpeg --with-system-zlib --enable-pango --enable-svg --enable-system-cairo --disable-installer --disable-pedantic --disable-updater --disable-strip --disable-strip-libs --disable-install-strip --enable-single-profile --disable-profilesharing --disable-profilelocking --enable-default-toolkit=cairo-gtk2 --enable-official-branding --enable-ogg --enable-wave --enable-crashreporter --enable-dbus --disable-debug --disable-tests --disable-debugger-info-modeules --enable-ipc --enable-libnotify --enable-startup-notification --disable-system-sqlite --disable-necko-wifi --enable-webm --with-system-libvpx=/usr --enable-tracejit --with-system-nspr --with-nspr-prefix=/usr --with-system-nss --with-nss-prefix=/usr --x-includes=/usr/include --x-libraries=/usr/lib64 --with-system-libevent=/usr --enable-system-hunspell --disable-gnomevfs --disable-gnomeui --enable-gio --enable-storage --enable-places --enable-places_bookmarks --enable-oji --enable-mathml --disable-mochitest --prefix=/usr --libdir=/usr/lib64 --disable-gconf --disable-mailnews --enable-canvas --enable-safe-browsing --with-system-png --enable-system-ffi --with-default-mozilla-five-home=/usr/lib64/firefox --target=x86_64-pc-linux-gnu --disable-system-sqlite --enable-extensions=default
Removing --enable-system-cairo should fix this.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 518172
Whiteboard: [closeme 2012-04-27 DUPLICATE 518172]
You need to log in before you can comment on or make changes to this bug.